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The Melodyne Help Center and this PDF document

This PDF document was generated automatically from the contents of the Melodyne Help Center. It 

contains what, on the date indicated on the front page, were the latest versions of the text and 

images.

You will find the comprehensive and invariably up-to-date Melodyne Help Center along with 

numerous films and inspiring tutorials, as well naturally as the latest version of this PDF document, on 

our web site. Why not take a look? Just follow the link at the foot of each page of this PDF.
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Switching to Melodyne studio trial mode

   Switching to trial mode • Comparing editions • Expiry of the trial period • Convinced?

Troubleshooting

  I’m not sure how to install Melodyne correctly. • I have installed Melodyne but cannot find it. • I’ve installed 

 Melodyne but do not know how to activate it. • I am getting error messages and cannot complete the 

  activation. • I would like to install Melodyne again but no longer have the installation program. • I’m not sure 
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Loading and saving audio

In this tour, you will learn how to open audio files and export audio from the stand-alone 

implementation of Melodyne.

Please note: The amount of memory Melodyne requires depends partly upon the length of the files 

you are transferring to it or loading but mainly upon the number of notes they contain: the more notes 

a file contains, the longer the detection process takes and the more memory it requires. This makes it 

difficult to formulate a concrete rule, but, in general: with files longer than an hour, the detection 

process is generally slow; files longer than two hours, however, may be impossible to load or transfer 

at all, due to shortage of memory. In such cases, please divide the file up and transfer or load only 

the segments that you actually wish to edit in Melodyne.

Tempo adjustment when audio files are loaded

When an audio file is opened, Melodyne detects not only the notes it contains but also the musical 

tempo. Whether this tempo information is used to adjust the tempo of the file depends upon the 

status of the Auto Stretch switch in the transport bar.

For details, see the tour “Tempo detection and Auto Stretch”.

Loading files from the menu

Choose File > Import Audio...; then use the file selector to navigate to the desired audio file, and open 

it.

You can load audio in various uncompressed formats such as WAV and AIFF but also MP3 – or CAF 

– files as well as Apple Loops.

Alternatively, you can load audio files by choosing File > Open from the menu bar. In this case, if you 

select more than one audio file, a separate project (with its own tab above the transport bar) will be 

created for each file.
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Loading files by drag ‘n’ drop

You can load files into Melodyne by drag ‘n’ drop from the following locations:

your operating system’s file manager (e.g. Finder or Explorer)

Melodyne’s File Browser (which displays folders on your hard disk – see below)

Melodyne’s Project Browser (which shows the audio files the project is already using) When 

dropping audio files into Melodyne, they will snap to the grid if it is active. You must therefore 

deactivate it if you wish to position the files freely, i.e. without the grid influencing the result.

Tip: It is not only audio files but also Melodyne project files (MPD files) that can be dragged and 

dropped at a desired point in the timeline, in which case Melodyne imports into the current project all 

the contents of the MPD file.

Whenever you use the drag ‘n’ drop procedure, pay attention to the status of the Auto Stretch switch, 

as this determines whether or not the imported file adopts the tempo of the project.

The File Browser

The File Browser can be displayed in the Info pane and offers you a user-friendly way of accessing 

audio file folders you use often.

Initially, the File Browser is empty. Drag the folders you wish to include from your computer’s file 

manager (e.g. Finder or Explorer) into the empty grey pane.
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You can drag to the File Browser folders from different storage devices and different hierarchical 

levels within your file structure. In the Browser itself, all the folders appear at the same level in the 

form of a simple list. To the left of each entry is a small triangle that can be used to expand the folder 

in question. In this way, you can navigate down through the hierarchy of folders.

Any time you double-click on a folder, you “plunge into it”, so to speak, and the rest of the directory 

structure in the File Browser is hidden. The pop-up button at the top of the browser displays the path 

of the current folder and allows you to ‘resurface’ (i.e. return to the highest level) and regain access to 

the hidden folders.

Audio files are indicated in the File Browser by either a colored blob or a grey waveform. Files with a 

colored blob already possess an MDD file. This contains information regarding the tempo and note 

detection of the file, which means it can be loaded quickly without having to go through the detection 

process again. Files with a grey symbol do not possess an MDD file.

To the right of each audio file, you will see a Play button to allow you to preview (or ‘audition’) its 

contents. The volume button for this preview function is to the right of the pop-up button displaying 

the folder name or level.

Saving audio: the Export window

To save audio material in the form of an audio file on your hard disk, choose File > Export... from the 

menu bar. This opens the Export dialog, in which you will find a variety of options.
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From the top line, you select the file format, the sample rate and the bit resolution of the file(s) to be 

exported. (Exporting MIDI is dealt with in separate tours). From the second line, you select the scope 

(in time) of the material to be exported. Whether the material is exported in mono or stereo depends 

upon the number of channels in the original files.

For the Range (i.e. the temporal scope), the following options are available:

Entire Length: everything from the beginning of the first track to the end of the last.

Cycle Range Only: only the segment of the timeline between the cycle locators.

The “Include tails” box should be checked in cases where, for example, you have chosen Cycle 

Range Only but some notes in the selection overlap the end of the range. Selecting this option 

extends the range slightly so that the tails of notes are not chopped off and the decay is preserved.

Click the Export button to begin the export with the selected options. A file selector will open so that 

you can choose the storage location.

The ‘Replace Audio’ command

The ‘Replace Audio’ command in the File menu allows you to save an audio file edited in Melodyne 

under its original name without recourse to the Export dialog. The original file is then replaced by the 

version edited in Melodyne, but at the same time Melodyne also saves the original file, adding “orig” 

to the filename. Access to the unedited original remains possible, therefore, at any time, as it has not 

been deleted but simply renamed.

Saving with “Replace Audio” is primarily useful when you define Melodyne in your DAW as the 

external sample editor: at the push of a button inside the DAW, you can then open a file for editing in 

Melodyne, whereby saving it subsequently with “Replace Audio” ensures that the file is “given back” 

to the DAW automatically. This is because the DAW uses the name of the file to identify and access 

it, and since Melodyne is no longer changing the name, saving the edited file in Melodyne with 

“Replace Audio” makes it instantly available to the DAW.
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The advantage of defining Melodyne as a sample editor in your DAW (as opposed to using it as a 

plug-in), is that the transfer process, which with long files can be time-consuming, is replaced by a 

swifter load operation. The disadvantage is that you cannot hear your editing in the context of the 

arrangement and cannot make the audio file available once more to the DAW without “freezing” it. 

This is different from working with the Melodyne plug-in, which you can leave open until the final mix, 

making further changes at any time and hearing them in the context of the DAW arrangement.

The replacing of audio files and the saving of Melodyne project files are processes that influence one 

another. Suppose, for example, you have opened a file from the DAW in Melodyne and performed 

some editing, but think you might wish to revise this later. In this case, you should save your editing in 

a Melodyne project file (suffix “.mpd”). This .mpd file initially references the audio file provided by the 

DAW.

If you wanted at this stage to give the edited audio file back to the DAW, the “Replace Audio” 

command, if it were available, would have unintended consequences, because Melodyne’s .mpd file 

would be referencing the newly edited version of the audio file not the original. This would mean that 

if in the course of further editing you tried to restore a note you had previously deleted, you would 

discover that this was impossible, as the note would no longer be present in the file. To avoid this 

problem, when replacing an audio file, Melodyne changes the reference in the .mpd file – whenever 

one has been created – from a reference not to the  audio file but to the original (i.e. to the file edited

with “orig” added to its name) before saving the .mpd file again. This is why the “Replace Audio” 

command disappears from the File menu whenever an .mpd file is created and “Save and Replace 

Audio” appears there instead.

This solution allows you, on the one hand, immediate access to the edited audio file in the DAW, and 

on the other, the freedom to undo, or make further, changes at any time in Melodyne simply by 

loading the .mpd file, as this retains access to the original.

Please note: The “Replace Audio” command is only available for WAV or AIF files. With compressed 

audio formats, such as .mp3 or .caf, you cannot overwrite the original; instead you must create a new 

WAV or AIF file using the “Export” command from the File menu.

http://helpcenter.celemony.com/hc-2/?lang=en&startPageEdition=melodyne-assistant
http://www.celemony.com


Melodyne 4 assistant - Stand-alone

   © Celemony Software GmbH 2020 • Last updated on 12/07/2020 • Help Center • www.celemony.com 12

Recording audio

In this tour you will learn how to record audio with the stand-alone implementation of Melodyne and 

what has to be borne in mind when doing so.

Audio and recording preferences

Before recording for the first time in the stand-alone implementation of Melodyne, you should open 

the Preferences property sheet to examine, and if necessary change, the audio and recording 

settings.

To open the Preferences property sheet, choose Program (macOS) or File (Windows) followed in 

each case by Preferences..

On the Audio page, you will see the general audio settings. If you have already loaded, played back 

and edited files with Melodyne and everything functioned, you can just leave the existing settings. (On 

the Mac, the internal Core Audio hardware is used by default; under Windows, the ASIO driver of 

your audio hardware should be selected).

On the Recording page, you can select a file format for your recordings, such as WAV or AIFF.

Handling the tempo and the metronome

Before you begin the first recording in a new Melodyne project, you should devote some thought to 

the matter of tempo. In a new document, the tempo and time signature fields are initially empty; 

instead of a value in each case, a simple dash (“–”) is displayed. The Time Ruler, initially, is calibrated 

in seconds. At this stage, then, there is no musical tempo.
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You now have two choices: you can either enter the tempo manually and record in time to a 

metronome click or begin recording with the tempo field still empty, allowing Melodyne to detect the 

tempo automatically.

To enter the tempo manually, proceed as follows (the default values, unless others are entered by 

hand, are 120 BPM for the tempo, 4/4 for the time signature, and quarter note (crotchet) intervals for 

the Time Grid):

Enter the desired value in beats per minute (BPM) in the tempo field

Enter the desired values for the numerator and denominator of the time signature (e.g. 6/8)

Enter a musical note value instead of seconds in the menu for the Time Grid

Click on the icon between the time signature and tempo fields in the transport bar to activate 

the metronome. When you choose this procedure, Melodyne assumes that you intend the 

tempo to be constant, so any fluctuations in tempo will be revealed by a discrepancy between 

the position of the blobs and that of the grid lines. The fact that you have opted for a constant 

tempo will be indicated by an equals sign (“=”) before the tempo in the transport bar.

To activate the metronome, click on the icon between the time signature and the tempo in the 

transport bar. To make the click quieter or louder, click on the same (metronome) icon and drag 

downwards or upwards without releasing the mouse button.

If you are used to working with DAWs, you may be more comfortable setting the tempo manually and 

recording to a click. Since Melodyne is extremely good at detecting the tempo, however, it is in many 

cases easier and more practical simply to allow Melodyne’s tempo detection routines to determine the 

tempo for you.

Instead of initializing the tempo, time signature and Time Grid values manually, as just 

described, begin recording with the tempo and time signature fields empty. Now you no longer 

need a click to listen to as you record because Melodyne will detect the tempo and tempo 

fluctuations within the recording and adjust the grid lines and subsequent click accordingly. 

Instead of entering a numerical value for the tempo, in other words, you are determining the 

tempo through your performance.

This will result in any fluctuations in tempo within the performance being considered deliberate and 

the tempo being interpreted as variable. The value in the tempo field will therefore be constantly 

changing in the course of playback, and the mesh of the Time Grid will expand or contract 

accordingly (i.e. distance between grid lines will increase or decrease) as the tempo changes. The 
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fact that the tempo is variable is indicated by the presence of a tilde (“~”) before the value in the 

tempo field.

Enabling, starting and stopping recording

Move the playback cursor to a point just to the left of that at which you intend to begin 

recording. This will give you a cue.

Click on the record button in the transport bar, to activate Melodyne’s record mode.

Begin the actual recording by clicking the play button and commence recording.

The cycle range can also be used during a recording to play back a specific segment of the track 

repeatedly. The recording, however, ignores the cycle and appears on your track as though the cycle 

were inactive.

By clicking on the record button in the transport bar as the playback proceeds, you can punch in and 

out (i.e. toggle record mode on and off). When you halt the playback in Melodyne, all recording 

ceases.

You can discard a poor recording simply by choosing Undo. You can listen to a recording even while 

the detection process is underway and cancel if you wish.
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The Project Browser

The Project Browser shows you all the audio files used by each project and helps you manage them 

and locate missing files.

Opening the Project Browser

Both the stand-alone implementation and the plug-in possess a Project Browser. In each case, this is 

opened by clicking the “Project” tab in Melodyne’s info pane.

The Project Browser in the stand-alone implementation

In the stand-alone implementation of Melodyne, the Project Browser displays all the audio files that 

you have integrated into the project – whether via the File menu, by dragging and dropping, or by 

recording. If you click a blob in the Note Editor, the Project Browser will highlight the audio file to 

which the note in question belongs.

You can drag and drop files from the Project Browser into the project in the same way as from the 

File Browser. You might do this, for example, when you wish to use the same file in several different 

places within the project.

Please note that the Auto Stretch Switch also governs the dragging of files from the Project Browser: 

if Auto Stretch is switched on, the tempo of the file will be adjusted to that of the project; if it is 

switched off, the inserted file will retain its original tempo.
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Unused and missing audio files

In both the stand-alone implementation and the plug-in, audio files are color-coded in the browser as 

follows:

Black: The file is present and being used by the project

Gray: The file is present but not in use (e.g. because you have deleted from the project all the 

notes it contains)

Red: The file is needed but unavailable

The reason unused files are retained in the Project Browser rather than being deleted automatically is 

that this allows you to undo the delete operation, which would otherwise be impossible.

If Melodyne cannot find one of the files it needs to use – either because it has been deleted or 

because it was not moved to a new computer along with the other project files – the missing file will 

be shown in red in the Project Browser. The notes belonging to such a file are shown in gray with a 

red outline in the Note Editor and are muted during playback.

Commands in the drop-down and context menus

The drop-down menu opened by the cog icon in the Project Browser as well as the context menu in 

the same browser offer the following commands, some of which are designed to facilitate the 

assignment of missing files.

Set Path for Transfers... (only in the plug-in): This allows you to specify where the transfer files 

should be stored, as is explained above.

Show in Finder/Explorer: If you choose this command after right-clicking on a file in the Project 

Browser, a Finder/Explorer window will open showing you the location of the file.

Copy File(s): This copies the selected file(s) onto the clipboard. This might be useful, for example, if 

you have passed on to another user a project missing one or more of the requisite transfer files; by 

selecting the missing file(s) in the Project Browser, choosing Copy File(s) and then pasting the 

contents of the clipboard onto a hard disk or other storage medium, you can remedy the error swiftly 

without having to hunt around for the missing file(s).

Copy Path for File(s): This copies as text to the clipboard the path of the selected files. This is useful 

if you need to send someone a list of missing files.
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Find Missing Files: This opens a file selection window that allows you to locate the missing file on 

your hard disk and “show” it to Melodyne.

It is advisable to save your project after reassigning files, in order to store the updated references.

Copy External Files to Project Folder (only in the stand-alone implementation): This command 

results in all the files that you have imported into your project from different locations on your hard 

disk, whether via the File menu or by drag ‘n’ drop, being copied into the audio folder of your 

Melodyne project. This folder, which is created when your Melodyne project is first saved, is on the 

same level in the file hierarchy, and bears the same name, as the MPD file of the project, but with the 

suffix “_Audio”. It is advisable to save your DAW project after executing this command, in order to 

store the updated references.

Delete Unused Files in Project Folder: If you are certain that you will have no further need for files 

marked as unused in the Project Browser, this command allows you to delete them and liberate 

space on your hard disk.

The last two commands in the context menu allow you to specify whether the files in the Project 

Browser should be displayed in alphabetical order or according to status (missing, used, unused).
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Project documents

In the stand-alone implementation of Melodyne, you store your projects as MPD documents. You can 

open and work on several projects at the same time.

Opening a project document

As soon as you launch the stand-alone implementation of Melodyne, a new empty project is created. 

To load an existing project, choose File > Open from the menu bar. The Open Recent command 

offers you swift access to the documents opened most recently.

Melodyne’s project documents have the suffix “.mpd”.

Creating a new project document and switching between projects

Choose File > New to create a new empty project.

Melodyne allows you to work on several projects at the same time. It is therefore unnecessary to 

close the current project before opening another or creating a new one. Each open project is 

represented by a tab just below the menu bar at the top left of the screen. Tabs are only displayed 

when more than one project is open.

To switch to another project, simply click on the corresponding tab.

Closing and saving projects

To close a project, either choose File > Close or use the keyboard shortcut [Command]+W. Provided 

more than one project is open at the time, you can also close a project by clicking on the ‘x’ symbol to 
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the left of the project name on the tab. If a project contains unsaved changes, an asterisk is displayed 

beside the project name on the tab.

If you attempt to close a project containing unsaved changes, you will be offered the choice of saving 

your changes and closing the project (Save), closing the project without saving your changes 

(Discard) or returning to the open project (Cancel). The same dialog box is displayed whenever you 

attempt to quit Melodyne while a document with unsaved changes is open.

With the commands Save and Save As... in the File menu, you can save a project at any time, under 

its existing name or a new name, respectively.

The command Revert to Version Last Saved has the effect of restoring a project to the state it was in 

when last saved i.e. of discarding all the changes you have made in the interim.

The audio folder of a project

When you save a project for the first time, as well as the project’s MPD file, Melodyne creates at the 

same level in the directory hierarchy, a folder for the project’s audio files. This has the same name as 

the project but with the suffix “_Audio”.

All the recordings you have made within the project and all the samples you have imported using the 

Project Browser are stored in this folder.

If you wish to archive a project or pass it on to another user, you must archive or pass on not only its 

MPD file but also this audio folder.

Copying audio from one open project to another

Whenever more than one project is open in Melodyne, you can copy individual notes or an entire 

audio source from one project to another. Simply select the audio material, copy it, switch projects, 

and paste.

It is also possible to drag an audio file from the Project Browser of one project to the tab of another. 

As you drag the file over the tab, pause to allow Melodyne time to switch projects, before dropping 

the file at the desired location within the destination project.

Importing projects

You can import the contents of one project into the current project by dragging its MPD file from your 

computer’s Finder/Explorer or Melodyne’s File Browser.

If you select several MPD files in Melodyne’s Open dialog, these will be loaded simultaneously as 

separate projects, each with its own tab.
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Using Rewire

Via Rewire, you can connect the stand-alone implementation of Melodyne to your DAW and transmit 

audio from Melodyne to your DAW.

About the Rewire interface

The stand-alone implementation of Melodyne’s support for the Rewire protocol provides an 

alternative to running Melodyne as a plug-in. This is particularly useful when you want to take 

advantage of certain aspects of the stand-alone implementation that are not offered by the plug-in (e.

g. the ability to import material from libraries or its tempo detection/editing functions) or if your DAW 

either has no plug-in interface or has one that is incompatible with Melodyne. For this mode of 

operation to be possible, of course, your DAW must be capable of supporting Rewire and of doing so 

in “Host” mode; but the overwhelming majority of DAWs are.

When Rewire is active, the transport functions and tempo of Melodyne and the DAW are coupled: 

commence playback in one, and the other starts too, with both running automatically in sync. In 

addition, audio signals can be transmitted from Melodyne (the Rewire slave) to the DAW (the Rewire 

host), where you can access them from the mixer.

Establishing the Rewire link

To use Rewire with Melodyne, you must launch your DAW first and the stand-alone implementation of 

Melodyne subsequently. Melodyne will detect the presence of a Rewire master (your DAW) and 

thereupon activate a device called “Rewire” in the preferences property sheet. If, on the other hand, 

you launch Melodyne when the DAW is not running, Melodyne will revert as normal to the audio 

device last used.

You cannot change the sampling rate, the size of the buffer used by Melodyne or the input channels 

in Rewire mode, as the sampling rate is dictated by your DAW, the buffer sized is fixed and the input 

channels are not available in Rewire mode.

http://helpcenter.celemony.com/hc-2/?lang=en&startPageEdition=melodyne-assistant
http://www.celemony.com


Melodyne 4 assistant - Stand-alone

   © Celemony Software GmbH 2020 • Last updated on 12/07/2020 • Help Center • www.celemony.com 21

Activating Rewire in your DAW

Please read the documentation of your DAW to discover how to enable its tracks for Rewire – the 

procedure varies from DAW to DAW. Regardless of the exact procedure, however, you must select 

the Rewire device “Melodyne” as the input to the desired track or mixer channel in the DAW.

The transmission of audio via Rewire

When you are using Rewire, you can select from the Master Output drop-down list on the Audio page 

of the Preferences dialog any of four possible stereo pairs for the transfer of audio signals to the 

DAW. By default, Channels 1 and 2 are selected. Please make sure that the selected input channels 

in the Rewire device in your DAW match the settings in Melodyne.

Tip: If you use the Melodyne Rewire device with different input channel settings on different tracks of 

your DAW, you can route the output signal from Melodyne to these different tracks by selecting the 

corresponding Master Output channels and are not therefore obliged to switch to your DAW to do this.

Note that Rewire is used to transfer audio from Melodyne to your DAW, not from your DAW to 

Melodyne. If you want to edit audio tracks from your DAW in Melodyne when the two are connected 

via Rewire, you must first export (“bounce” or “render”) the tracks in your DAW, and then import them 

into Melodyne.

Tip: When exporting tracks from your DAW, always begin at Bar 1, as then they will automatically be 

aligned correctly when imported by Melodyne. This makes it easy to avoid timing discrepancies.

Starting and stopping playback

The project loaded in Melodyne will start in sync with the DAW whether you activate playback from 

within the DAW or from within Melodyne. By the same token, you can halt the playback either from 

Melodyne or the DAW.
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Melodyne adopts the tempo of the DAW and speeds up, or slows down, the playback of the project 

as necessary to maintain synchronicity with the DAW.

Synchronization

If a Melodyne project is to run in perfect sync with the DAW, the tempo of the Melodyne project must 

be the same as that in the DAW at the moment when the first files are imported into Melodyne from 

the DAW. To ensure that this is the case, when creating the Melodyne project you intend to use for 

the Rewire connection, in the transport bar type in the tempo in BPM that is displayed in the DAW. 

Then switch off Auto Stretch and import the audio files.

If your DAW project has a variable rather than a constant tempo, this is obviously not something you 

can just type in. In this case, you must export a MIDI file from your DAW that runs the entire length of 

the project, and then use the Import Tempo command in Melodyne’s File menu to import this MIDI 

file; this will allow Melodyne to create a tempo map of the project. Once you have done this, you can 

import the audio files with Auto Stretch switched off.

By following this procedure, you will be able to operate the DAW and Melodyne together in such a 

way that audio comes on one side from the DAW and on the other from Melodyne. If you now change 

the tempo in the DAW, you will not need to take any further action, as Melodyne thereafter will follow 

tempo changes in the DAW automatically.

http://helpcenter.celemony.com/hc-2/?lang=en&startPageEdition=melodyne-assistant
http://www.celemony.com


Melodyne 4 assistant - Stand-alone

   © Celemony Software GmbH 2020 • Last updated on 12/07/2020 • Help Center • www.celemony.com 23

Playback, navigation, zooming

This tour will give you an overview of the functions Melodyne offers for navigation and the playing 

back of audio.

Controlling playback using the keyboard and transport bar

The plug-in implementation of Melodyne is integrated into the DAW and keeps perfectly in step with 

its playback. When you reposition the DAW, this information is conveyed to Melodyne, which mirrors 

the new position. As soon as the DAW starts, Melodyne also starts. It is not possible to start, stop or 

reposition the DAW’s playback cursor from within Melodyne.

With the stand-alone implementation of Melodyne, you start and stop the playback using the buttons 

in the transport bar at the top or by pressing the space bar. If you hold the [Alt] key at the same time, 

playback will be confined to the current selection.

You can also control playback in Melodyne Stand-Alone using the numeric keypad of your computer. 

The shortcuts can be selected from the Preferences dialog, the default settings being as follows:

Playback/Pause [space bar]: Stop or Start playback from the current position of the playback 

cursor

Start [Enter] when stopped: Commence playback from the current position of the playback 

cursor

Start [Enter] during playback: Jump to, and continue playback from, the last starting point

Stop [0 on the numeric keypad] during playback: Stop and jump to the last starting point

Stop [0 on the numeric keypad] twice in succession: Jump to the beginning of the project

In both the stand-alone and plug-in implementations of Melodyne, the arrow keys on the keyboard 

can be used to step through the blobs. When playback is stopped, the blob currently selected will 

sound.

Please note that you can define a wide variety of keyboard shortcuts – including new playback 

shortcuts – using Melodyne’s Preferences dialog. If for any reason you are not satisfied with the 

default shortcuts, you can redefine them at will.

Controlling playback, scrubbing and zooming using the Time Ruler

The following playback functions are available in both the stand-alone and plug-in implementations of 

Melodyne – in the Melodyne plug-in, however, only when the DAW is stopped; as soon as it starts 
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again, Melodyne plug-in resumes its shadowing of the DAW as described earlier.

 

Double-click in the Melodyne Time Ruler (or directly in the background of the Note Editor) to 

commence playback from the position in question. If you hold down the [Alt] key as you double-click 

in the Time Ruler, playback will be confined to the current selection.

Click in the Time Ruler to move the playback cursor to the position in question and halt playback at 

the same time.

Click and drag in the Time Ruler to scrub through the audio material.

By dragging upwards or downwards, you can zoom the display at the current position. Scrubbing and 

zooming can be used in combination, allowing you to navigate and position the cursor intuitively, 

setting the zoom factor at the same time.

Resizing the window

To change the size of the window, click and drag the bottom right-hand corner. The procedure is the 

same for both the stand-alone and plug-in implementations of Melodyne.

Scrolling and zooming in the Note Editor

Select the Scroll Tool (the hand icon) from beneath the main tool or hold down the [Command] and 

[Shift] keys to move the display area with the mouse.
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Select the Zoom Tool (the magnifying glass) from beneath the Main Tool or press [Command]+[Alt] to 

zoom the display with the mouse. You can zoom horizontally and vertically at the same time – with 

different levels of intensity in each case.

[Command]+[Shift]+double-click zooms in on one blob or several (if several are selected). A 

corresponding double-click in the editing background returns you to the previous zoom level.

If your hardware supports the corresponding functions, you can also scroll and zoom with the mouse 

and trackpad:

The mouse wheel and swiping with two fingers on the trackpad can be used for horizontal and 

vertical scrolling.

Pinching with two fingers on the trackpad zooms the display simultaneously on the horizontal 

and vertical planes.

Drag the horizontal or vertical scrollers (i.e. the scroll boxes or ‘thumbs’)  to move the display. The 

horizontal scroller contains a miniaturized image of the contents as an orientation aid.

Drag the ends of the scroller to zoom the display.
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If you are editing a particularly long audio file, you may find the reduced size of the scroller makes it 

difficult to achieve the desired zoom resolution. In that case, you can zoom in further by holding down 

the [Command] and [Alt] keys whilst dragging in the edit pane or else by dragging vertically in the 

Time Ruler.

If you pull one end of the horizontal or vertical slider as far as it will go and hold it, you can increase 

the vertical or horizontal size of the area displayed. This can be useful in the plug-in, for example, 

when you have only transferred the first three bars (measures) of your material but wish to insert 

something at bar 20.

Double-click in the center of the scroller to zoom in or out just enough to ensure that all the blobs are 

displayed. If cycle mode is active, double-clicking on the horizontal scroller zooms the display just 

enough to ensure that the entire contents of the cycle range are visible.

Use the slider in the bottom right-hand corner near the Note Editor to alter the height of the blobs. 

This does not alter their volume. Your likely motive will be to obtain a clearer view of material 

containing a lot of particularly quiet or particularly loud notes.

A note about automatic scrolling in the Note Editor

If you have selected one or several notes, Melodyne assumes that you wish to see and edit them, 

and exercises the requisite restraint by deactivating the auto-scroll function temporarily. Only when 

you deselect the notes (for example, by clicking in the background of the Note Editor) and restart the 

playback does the display resume its pursuit of the playback cursor.

Similarly, if you move the horizontal scroller so far during playback that the playback cursor actually 

disappears from the screen, automatic scrolling will be deactivated. Stopping and restarting in this 

case will reactivate the auto-scroll function.

If automatic scrolling has temporarily been deactivated, the auto-scroll icon in the bottom right-hand 

corner of the Note Editor takes the form shown here.

http://helpcenter.celemony.com/hc-2/?lang=en&startPageEdition=melodyne-assistant
http://www.celemony.com


Melodyne 4 assistant - Stand-alone

   © Celemony Software GmbH 2020 • Last updated on 12/07/2020 • Help Center • www.celemony.com 27

Navigation and zoom functions

To resize the window (also in Plugin), drag the bottom right corner

Hold down the [Command]+[Shift] keys and drag the editing background of the Note Editor to 

move the area displayed

Use the mouse wheel to scroll up and down or else (holding the [Shift] key) left and right

A two-finger swipe on the trackpad can be used to scroll the display

A two-finger pinch on the trackpad can be used to zoom the display.

[Command]+[Alt]+drag in the Note Editor serves to zoom the display horizontally and/or 

vertically

Drag vertically in the Time Ruler to zoom in on the area indicated

Press [Command]+[Alt] and use the mouse wheel to zoom both axes simultaneously

Press [Command] and double-click to zoom in on a blob or the current selection of blobs

[Command]+double-click in the editing background to restore the previous zoom setting

Drag the scrollers to move the display horizontally or vertically

Drag the ends of the scroller to zoom the display horizontally or vertically

Pull the left- or right-hand ends of the horizontal slider as far as they will go to increase the 

length of the section displayed (important in the plug-in e.g. when you have only transferred 

the first four bars and  are able to navigate only in this area but wish to insert something at bar 

20)

Double-click the scrollers to zoom in or out horizontally or vertically until all notes are displayed

The slider in the bottom right-hand corner governs the height of the blobs
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Cycle mode

In Melodyne’s cycle mode, a selected passage is repeated endlessly.

Defining the cycle range

To define a cycle range, click and drag in the lower part of the Time Ruler. If, as you do so, you hold 

down the [Alt] key, the Time Grid will be ignored, allowing you to position the start and end points 

(which we call the “cycle locators”) freely.

Switching cycle mode on and off

Double-click on the cycle range in the narrow strip immediately below the Time Ruler to toggle cycle 

mode on and off. When cycle mode is active, the cycle range is shown in dark grey

In the stand-alone implementation of Melodyne, you can also switch cycle mode on and off from the 

transport bar.

It is also possible by choosing File > Preferences > Shortcuts to define a keyboard shortcut for 

toggling cycle mode on and off.

Changing the length of, and moving, the cycle range

Drag the right- or left-hand locators to alter the length of the cycle range. If, as you do so, you hold 

down the [Alt] key, the Time Grid will be ignored, allowing you to position the locators freely.
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Drag the middle of the cycle range to move it ‘en bloc’ to the left or right. If, as you do so, you hold 

down the [Alt] key, the Time Grid will be ignored.

If you [Shift]+click near either of the cycle locators, it will move to the designated position. If, as you 

do so, you hold down the [Alt] key, the Time Grid will be ignored.

Defining the cycle range using a blob selection

To move the cycle locators to the beginning and end of the current blob selection (snapping to the 

grid) hold the [Shift] key and double-click anywhere in the cycle range. If you hold the [Alt] key as well 

as the [Shift] key as you do this, instead of snapping to the grid, the locators will be placed at the 

beginning of the first, and end of the last, blob in the selection.
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Display and other options

Melodyne offers for the user interface and working in the Note Editor various options that allow you to 

adapt the appearance and behavior of the program to your tastes.

Showing and hiding elements of the user interface

Melodyne’s user interface can be adapted to a variety of different work situations and demands. You 

will find the means of doing so in the Options menu as well as the interface itself.

The illustration shows which icons in the user interface of the stand-alone implementation of 

Melodyne correspond to which items in the Options menu.

Note Editor (A): Various options for the Note Editor that are described in detail below.
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Scale Editor (B): Shows/Hides successively one, two or all three panes of the Scale Editor 

window.

Pitch Grid ©: Offers the choice between various options for the Pitch Grid.

Time Grid (D): Offers the choice between various options for the Time Grid.

Show Info Pane (E): Hides the info pane or shows it on the left- and/or right-hand side of the 

screen.

Auto-Scroll Note Editor (F): When this option is activated, the display in the Note Editor follows 

the playback cursor.

A note about automatic scrolling in the Note Editor: If you have selected one or several notes, 

Melodyne assumes that you wish to see and edit them, and exercises the requisite restraint by 

deactivating the auto-scroll function temporarily. Only when you deselect the notes (for example, by 

clicking in the background of the Note Editor) and restart the playback does the display resume its 

pursuit of the playback cursor.

Similarly, if you move the horizontal scroller so far during playback that the playback cursor actually 

disappears from the screen, automatic scrolling will be deactivated. Stopping and restarting in this 

case will reactivate the auto-scroll function.

If automatic scrolling has temporarily been deactivated, the auto-scroll icon in the bottom right-hand 

corner of the Note Editor takes the form shown here.

All the options described below relate to the Note Editor and are found by choosing Options > Note 

Editor Options from the main menu or by clicking the cog icon in the top right-hand corner of the Note 

Editor.

Please note that these options can be selected independently for Edit and Note Assignment modes.

Show Pitch Curve

If you check the option Show Pitch Curve, a thin line tracing the exact pitch of the tone at each instant 

will be superimposed on the corresponding blob.

On the left, you can see the ‘naked’ blobs (with none of the Note Editor display options selected) and 

on the right, the same blobs with the Show Pitch Curve option checked.
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Regardless of whether or not this option is checked, the pitch curve will be displayed whenever the 

Pitch Tool is selected.

Show Note Separations

If you select the option Show Note Separations, gray vertical lines appear at the beginnings and 

endings of notes indicating their limits or separations.

Note Separations are either shown as lines (soft separations between connected notes) or thin 

brackets (hard separations).

Note separations are always displayed when the independent Note Separation Tool is in use, 

regardless of whether or not the menu entry is checked.

Show Note Tails

In the detection and display of notes, Melodyne editor draws a distinction between the notes 

themselves and their tails – notes being the events of musical relevance and tails depicting the non-

musically-determined fading-away of the sound. The share of the reverberation ascribed to a given 

tone, for example, is reflected in its tail. The Show Note Tails option allows you to decide whether the 

reverberative phase of notes should be displayed or hidden. This is likely to depend upon whether 

you prefer to concentrate upon their musical or their acoustic aspects.
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If the tail is not displayed, the end of the musically relevant part of the note provides the handle you 

can drag with the Time Tool to make the note longer or shorter. Any reverberation present will in this 

case automatically be governed by the changes made. This display option serves to provide a clearer 

overview of the intended musical events.

If the note tail is displayed (assuming it has one), it is this that provides the handle for the Time Tool. 

Show Note Tails is the option most suitable when what is sought is as authentic a picture as possible 

of the sounds actually heard – including any reverberation present.

Show Blob Info

With the option Show Blob Info, you can elect to show or hide a variety of display elements designed 

to facilitate working with individual notes.

The most striking of these elements is the Local Pitch Ruler that appears directly in front of any note 

over which you move the mouse pointer. Within the blob itself, thin lines mark the drag zones for the 

context-sensitive tools.

If you drag a blob when the Show Blob Info option is checked, a vertical line also appears in the Time 

Ruler aligned with the exact start of the note. This makes more precise positioning possible.

Show Intended Notes

If you check the option Show Intended Notes, gray frames appear around each blob.
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These invariably lie directly on the semitone and coincide exactly with a gridline. They represent, in 

other words, Melodyne’s assumptions (based on its own analysis of the audio) as to the intended 

pitch of the note and its intended position within the measure or bar. These assumptions generally 

turn out to be correct, but are not inevitably so. They are to be thought of as suggestions.

The frames also display the positions in pitch and time towards which the notes in question will 

gravitate if partial quantization is applied to them with the macros, which are also the positions they 

will snap to if you double-click on them with the Time Tool or Pitch Tool.

Highlight Notes During Playback

With this option, you can select whether or not you would like your eye to be drawn to the note 

currently playing back. Highlighting is mainly useful when the screen is thick with notes.

Monitor When Editing Blobs

When you shift the pitch of blobs in the Note Editor with this option selected, Melodyne plays for the 

purpose of orientation the sound of the note at the position originally clicked. You can turn this 

acoustic feedback on or off.
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Preferences and keyboard shortcuts

From the Preferences property sheet, you can select fundamental options governing the modus 

operandi of Melodyne as well as define a number of keyboard shortcuts.

Opening the window and general settings

In the plug-in implementation of Melodyne, you open the Preferences property sheet from the 

Settings menu; in the stand-alone implementation, choose Preferences from the program (macOS) or 

File (Windows) menu. The settings available in the stand-alone implementation differ slightly from 

those offered by the plug-in.

The following options, however, are available in both implementations of Melodyne. Any changes you 

make in either implementation apply to both.

Language: Determines the language of the user interface.

Pitch labels: Determines which system is used to name the notes – i.e. (descending 

chromatically) English (C, B, Bb etc.), German (C, H, B etc.) or Latin (Do, Si, Sib etc.).

Appearance: Here you can select between different contrast settings for the user interface.

Default tuning: Determines the frequency of the reference pitch A4 (the A above Middle C).

Maximum undo levels: Melodyne allows you to undo up to 100 actions. The default value, 

however, is 25. You can, if you wish, increase this value, which will consume more RAM, or 

you may prefer to reduce it, if memory is running short.

Show tooltips: Once you are thoroughly familiar with Melodyne, you may prefer to hide the 

tooltips, i.e. the explanatory text that appears as you move the cursor over the various icons 

and other elements of the user interface.

Audio and recording preferences

In both the stand-alone implementation and the plug-in, you will find the following two options:

Audio cache: Determines the location on your hard disk of the audio cache Melodyne editor 

requires for internal processing.

Audio cache size: Determines the maximum size of this audio cache.
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The following option is only found in the plug-in:

Detect audio after transfer: When this option is selected, the detection (analysis) of the audio 

material does not begin until the transfer is complete, thereby reducing the CPU load during 

the transfer. Select this option if your computer is not especially powerful and there are 

indications during the transfer that its resources are becoming overstretched (e.g. clicks, drop 

outs, extreme slowing-down of the system).

The Audio and Recording pages of the Preferences property sheet display the following additional 

options:

Audio device: allows you to select an audio driver or the audio hardware driven by it.

Sample rate: determines the sample rate used by Melodyne.

Buffer size: determines the size of the buffer used for audio editing. The smaller the value, the 

lower the latency but the greater the load on the CPU.

Ignore buffer underruns: If Melodyne Stand-Alone is running on a slow computer where the 

possibility of an overload (and an ensuing click or dropout) exists, by checking this box, you 

inform Melodyne that you consider the former to be the lesser of the two evils – the point being 

that audio hardware is often very sensitive to dropouts and can even in such cases cause the 

entire computer to crash. Check the box if ever this happens. Such occurrences are very rare, 

however, and most users can safely ignore this option.

Master output: selects the main output for Melodyne stand-alone. The level at this output is 

controlled by the Master Volume control in the transport bar. If your audio hardware only offers 

one output, this is automatically the Master output

Default input: selects the main input for Melodyne Stand-Alone. If your audio hardware only 

offers one input, this is automatically the Default input.

Audio file format: determines the file format used by Melodyne to store recordings. The most 

commonly used formats are WAV and AIFF.
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Shortcuts

The Shortcuts page of the Preferences property sheet allows you to customize the keyboard 

shortcuts used by Melodyne for a wide range of functions.

Click the triangle to the left of the category that interests you in order to see a list of the available 

commands.

Click on a command and then press the key or combination of keys that you wish to assign as its 

shortcut. Melodyne will assign the key or combination of keys to the command in question. Repeat 

the procedure for as many commands as you like.

To remove an unwanted shortcut, select the command in question followed by Delete. You can 

restore the factory defaults at any time by clicking the Reset button; you will be asked to confirm that 

this is your intention.

The Export and Import buttons allow you to save one set of keyboard shortcuts to a storage device 

and reload a set saved earlier. In this way, you can carry your shortcut preferences around with you – 

on a USB stick, for example – when moving from studio to studio.

Check for Updates

On this page, you can determine whether Melodyne checks for updates automatically or manually i.e. 

only when you click the ‘Check Now’ button, which you can do at any time.
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Audio characteristics and algorithms

For the display and editing of different types of audio material, Melodyne employs different 

algorithms. Here, we outline which algorithms are available and for which types of audio material 

each is used.

The detection process

Melodyne analyzes the audio material to find the notes it contains and offer them to you for editing. 

We call this process “detection”.

In the course of the detection process, Melodyne itself takes a view as to what kind of material it is 

confronted with and decides which algorithm to use for the display and playback of the notes. You 

can tell which algorithm is selected at any given time by the check mark in the Algorithm menu as well 

as by the blobs in the Note Editor.

The Melodic algorithm

Melodic material is monophonic, by which we mean it is such that only one note is ever sounding at 

any given instant. Please bear in mind, however, that reverberation can cause notes to overlap even 

in monophonic material, creating, in effect, a kind of polyphony. If melodic material is to be edited in 

Melodyne, therefore, you should aim for as clean and “dry” (reverberation-free) a recording as 

possible.

The blobs representing notes in melodic material are displayed at different pitches. Whether the blobs 

are isolated or joined to other blobs depends on the way they were played or sung: staccato or legato.
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The Percussive algorithm

This category includes not only recordings of drums and other percussion instruments but also noise 

and atmospheric effects as well as other material in which Melodyne cannot detect any clear pitch in 

the sounds. When the Percussive algorithm is selected, successive drum strokes (for example) are 

distinguished, but they are all displayed at the same pitch. The blobs can still be raised or lowered in 

pitch, but the pitch ruler does not display the names of any notes but simply relative values in 

semitones. The scale functions are deactivated.

The Universal algorithm

The Universal algorithm is particularly suitable for complex signals containing both percussive and 

tonal elements. If, for example, you wish to alter the pitch, timing or tempo of an entire piece of music, 

this algorithm will deliver the best sound quality.

The Universal algorithm, like the Percussive one, displays all the detected notes at the same pitch. 

The Pitch Ruler displays no note names, merely relative values for the semitones, and the scale 

functions are deactivated. Please note that with files that have been detected using the Universal 

Algorithm, the Attack Speed Tool cannot be used. Attack speed handles will therefore not be 

displayed for the corresponding blobs and the Attack Speed field in the Note Inspector will be grayed 

out.
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Switching algorithms

You can at any time select a different algorithm to that chosen automatically for you by Melodyne. 

You might want to do this, for example, if you find that the material has not been interpreted in a way 

that suits your editing needs. To do this, while playback is halted, select the algorithm you prefer from 

the Algorithm menu. Melodyne will reinterpret the material in the light of your choice and adjust the 

display accordingly.

Note: when you do this, any editing performed prior to switching algorithms, including any copying of 

notes, will be lost . The right time to decide which algorithm you wish to use, therefore, is before you 

begin editing.

In the plug-in implementation of Melodyne, the choice of algorithm applies to an entire transfer, in the 

stand-alone implementation, to an entire audio file in the document being edited – collectively, we 

describe all such material as ‘audio sources’. Before you can change the algorithm applied to a 

particular audio source, you must first select one or more notes belonging exclusively to it. If you have 

selected no notes, or notes from two different audio sources, the Algorithm menu will be grayed out. 

In such cases, reduce your selection to notes belonging to one audio source only and it will be 

possible to switch algorithms.

When you switch algorithms, triggering a fresh detection, Melodyne looks at the status of the Auto 

Stretch switch: if the Auto Stretch function is activated, once the new detection is complete, the tempo 

of the file will also be adjusted: if Auto Stretch is not selected, the original tempo of the file will be 

retained.

Automatic or manual algorithm selection

Melodyne by default selects the most suitable algorithm automatically, basing its choice on the 

characteristics of the audio material. If, however, in an instance of the plug-in implementation of 

Melodyne or in the current document of the stand-alone implementation material has already been 

detected, when new material is transferred to that instance or a new file dragged into the stand-alone 

implementation, Melodyne will use the same algorithm for the new material as it used for the old – 

even if Automatic is selected.

Overruling the Automatic setting in this way is designed to ensure maximum consistency in the 

detection and avoid all risk of one of the transfers from a vocal track suddenly being interpreted as 

percussive. If, however, you have altered the algorithm of a transfer or file manually, the automation 

kicks in again afterwards, and no further attention is paid in the case of further transfers or files to 

already detected material.

This rule only applies when Automatic is selected as the algorithm. It does not apply, however, when 

you are using Melodyne with ARA; nor when, in the stand-alone implementation of Melodyne, a new 

file for which an MDD file already exists, containing the editing applied to its detection, is dragged into 

a document
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By setting a different default via the Algorithm menu, you can prevent Melodyne selecting an 

algorithm automatically for the detection.

Do not forget, however, when you no longer need to impose your choice of algorithm on Melodyne, to 

restore Automatic as the default setting. Otherwise, since Melodyne remembers your default selection 

even after you have quit the program, you might be surprised to discover when the program is next 

launched that your vocals have been interpreted as percussive.
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Note Assignment Mode

Since Melodyne invariably conducts an analysis (we call it “detection”) of the audio material before 

you can do any editing, the correctness or otherwise of this analysis has a considerable influence 

upon how well you are able subsequently to work with the material and how good the results of your 

editing sound. For this reason it is important to check whether Melodyne has detected the notes 

within your material accurately and if necessary correct any mistakes. This where Melodyne’s Note 

Assignment Mode comes in.

What editing the detection involves

When you are working in Note Assignment Mode, none of the changes you make has any audible 

effect on the notes themselves. All you are doing is ensuring that the notes that are displayed do 

actually correspond to those that were played or sung. In other words, you are bringing what you see 

into line with what you hear. In the process, you are working at all times on the display of the original 

recording and, with it, so to speak, on the basis for all musical changes made later with Melodyne. 

The sounder the basis, the better the eventual sound of your edits.

The fact that it is sensible and necessary to check and edit the detection and, with it, the 

interpretation of the audio material may seem tiresome at first sight. But it brings with it enormous 

advantages, for there are often several possible interpretations of the audio material, and which is the 

correct one in a given acoustic and musical context is for you, ultimately, to decide.

But don’t worry, the detection process in Melodyne is mainly automatic and the end result coherent. 

How much there is to edit in this mode depends upon the algorithm used and the audio material in 

question. With a dry recording of a single vocalist, for example, you will very rarely encounter 

problems. It may happen from time to time that a note is detected in the wrong octave, in which case, 

if you later transpose it, it will sound unnatural. Correcting the detection in such cases is a task swiftly 

accomplished. The same goes for percussive material, where it is generally only necessary to 

introduce or remove the occasional note separation.

What is edited and where

Like the choice of algorithm, Note Assignment Mode applies invariably to all the notes of i) a 

particular audio file, ii) a particular recording, or iii) a particular transferred segment – we will use the 

term “audio source” to cover all three. When the Note Editor contains notes from different audio 

sources, begin by selecting a note belonging to the source the detection of which you plan to edit.
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Now click the wrench (spanner) icon next to the toolbox of the Note Editor to activate Note 

Assignment Mode. The background in the Note Editor changes color to show that you are no longer 

in normal Edit mode but have switched to Note Assignment Mode. In Note Assignment Mode, what 

you see and hear is the original state of the audio source; any editing you may have performed on it 

previously is ignored here.

Any time you click on the blob icon (to the left of the wrench), you will leave Note Assignment Mode 

and return to edit mode. There you will hear once again the results of any editing you performed 

before switching to Note Assignment Mode. This only applies, however, if you have not changed 

algorithm in Note Assignment Mode, as any change of algorithm triggers a fresh analysis, and any 

time you trigger a fresh analysis – any time, in other words, the detection process is repeated – all 

editing that has been performed on the notes previously is lost.

The Algorithm Inspector

Whenever Note Assignment Mode is active, the Algorithm Inspector is available in the info pane.

Algorithm: The pop-up button at the top shows the current algorithm. With the menu displayed, you 

can select a different algorithm from the list, thereby triggering a fresh analysis. Warning: Any time 

you switch algorithms, all editing previously performed on the audio source in question is lost! For this 

reason, you should make a habit of checking to make sure the best algorithm has been selected and, 

if this is not the case, choosing a more suitable one  you begin correcting the analysis or before

editing notes.

Tip: In the stand-alone implementation of Melodyne, it is possible, prior to switching algorithms, to 

save the assignment file of the audio source (see below) and, if not satisfied with the new algorithm, 

reload it. In this case, the previous algorithm – and, with it, all your previous editing of the detection – 

will be restored; but  of the detection; any normal editing of the notes you may have performed in only

edit mode will, even in this case, be lost. This is an inevitable consequence of switching algorithms.
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In the preview section, you will find the following important options to assist you with the editing of the 

detection and the fine-tuning of the algorithm parameters.

Synth: The objective in Note Assignment Mode is to ensure that the notes displayed really do match 

the notes intended and played. Since, however, in Note Assignment Mode you are listening to the full 

original sound of the audio file you plan to edit and editing of the blobs has no audible effect, 

determining whether notes have been correctly detected is generally only possible on a visual basis. 

This is where the Monitoring Synth comes in: Using a synthetic tone generator, the Monitoring Synth 

plays the blobs exactly as they appear, thereby providing you with acoustic as well as visual 

feedback. You can toggle the synth on and off by clicking on the “Z” icon; click and drag upwards or 

downwards to control the volume.

The Monitoring Synth is not available when the Percussive or Universal algorithms are selected.

Tempo, Pitch and Formants: With these three controls, you can “simulate” changes to the 

corresponding parameters in order to examine their effect upon the current algorithm settings. 

Example: you have changed the formant character in the Algorithm Inspector. This change, however, 

has no effect until you shift the formants in normal edit mode, as in Note Assignment Mode you 

always hear the original state of the audio source. You would have, therefore, to leave Note 

Assignment Mode, shift the formants by way of experiment in normal edit mode, and then return to 

Note Assignment Mode if you felt any further adjustment to the formant character was necessary. The 

preview controls make such a procedure unnecessary: simply turn the formant control, and you can 

begin at once experimenting with the character slider without ever leaving Note Assignment Mode. 

The tempo and pitch controls operate much the same way. The values of all three preview controls 

only apply temporarily and are reset each time you leave Note Assignment Mode.

NB: When the synth is in use, the controls for pitch and formants are grayed out, as they cannot be 

used simultaneously.

The other parameters in the Algorithm Inspector relate to the behavior of the algorithm, allowing you 

to fine-tune it for the entire audio source.
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Playback Type: Melodyne applies two different processes for the playback of audio. The Melodic 

Algorithm employs as standard the playback type “Tonal”, whilst the other algorithms favor 

“Complex”. These choices are generally the best in practice but you can override them here if you 

wish.

The difference is most noticeable when time stretching is performed (and also when notes are 

transposed upwards): material with clearly recognisable pitches generally sounds better with the 

“Tonal” option. For material in which the pitch of notes is not clear and where noise components are 

more in evidence better results are generally obtained with “Complex”. Experimenting with the two 

playback types is therefore most useful when material falls between these two stools. Experiment with 

the tempo and pitch preview controls to see which playback type is best suited to your needs. Please 

note, however, that if “Tonal” is selected, the Character, Transients and Formant Character 

parameters described below are no longer available and therefore grayed out.

Tip: For the playback type “Tonal”, a variation called “Tonal (high)” is also available. If you are 

working with sopranos or very high-pitched melodic instruments (such as piccolos), instead of “Tonal”, 

you should try out the variant “Tonal (high)”, as this could enhance the sound quality. Voices or 

instruments with normal registers, however, are less well served by “Tonal (high)”, so its use in such 

cases is best avoided.

Character: This is a another pop-up button and allows you to select between a smoother and a 

crisper playback. If “Crisp” is selected, Melodyne uses a smaller processing window that allows fast 

acoustic movements in the signal to be reproduced more clearly. This setting is therefore best for 

percussive sounds and others with many fast tone changes. To soft, sustained sounds, however, the 

crisper setting can introduce a certain restlessness. To avoid this, opt for “Smooth” which employs a 

larger processing window and is therefore more suitable for the reproduction of smoother, more 

gradual tonal transitions.

Transients: This parameter is only available when the Universal and Percussive algorithms are in 

use. It determines how the transients in the signal should be handled during playback. With the slider 

fully to the right (the default position in the case of the Percussive algorithm), the transients are 
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clearer and more acute. As the slider is moved to the left, the transients become softer. By default, 

with the Universal algorithm selected, the slider is in the middle. Experiment to see which setting 

delivers the best sound with your own material.

Formant Correction Up/Down: Whenever you transpose a note in Melodyne, the formants are 

automatically corrected to avoid, in the case of vocals, the dreaded “Mickey Mouse” effect. Or, in 

technical terms, whenever you transpose a note a whole tone upwards, Melodyne automatically 

corrects the resulting formants by shifting them back down a tone, in this way preserving the original 

timbre. In the case of the human voice, this is generally what is wanted, but with an acoustic guitar 

perhaps not: With many sounds, it can add charm if the formants are transposed in parallel with the 

fundamentals – i.e. not automatically corrected.

The Formants Up and Down sliders are provided, therefore, to allow you to determine the degree of 

the automatic formant correction – independently for upward and downward transpositions. With the 

slider all the way to the right, the full 100% formant correction is applied; fully to the left, no automatic 

formant correction at all is applied. When you return to normal edit mode, you will only hear the effect 

of these parameters if you shift, or have shifted, the formants of one or more notes in the Note Editor. 

To simulate and test their effect in Note Assignment Mode, use the pitch controller in the preview 

section of the Algorithm Inspector. If the current value for this is positive, you will be able to preview 

the effect of the Up slider; if the current value is negative, you will hear the effect of the Down slider.

F(ormant) Character: When formants are shifted, this slider alters their weighting in the frequency 

range and therefore alters the sound of the shifted formants. Experiment to see with which setting 

your material is best reproduced. This parameter has no audible effect when you return to normal edit 

mode unless and until notes have been transposed in the Note Editor. To simulate and test its effect 

in Note Assignment Mode, use the formant control in the preview section of the Algorithm Inspector.

Separate Audio: When you are editing the detection of an audio source, Melodyne sometimes has a 

great deal of processing to perform in the background and large volumes of data to move in and out 

of its cache. The option Separate Audio gives you control over this behavior. If the Auto box is 

checked, with each change you make, Melodyne performs all the requisite calculations immediately. 

The advantage? Whenever you use the preview controls to test your algorithm settings, Melodyne 

accesses the latest data, and everything sounds exactly as it would in normal edit mode. The 

disadvantage? Melodyne sometimes needs to introduce a processing pause during which the 

progress indicator appears and your work is interrupted.

Since you do not always need the preview controls, you have the option of changing this behavior by 

clearing the Auto checkbox. The various calculations will then no longer be performed immediately 
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but only when you click the Now button or leave Note Assignment Mode. The advantage of this is that 

your workflow is not interrupted. The disadvantage is that the preview controls in this case do not 

always reflect the changes you have made. When there is a discrepancy between the previous data 

and the current state, the Now button flashes to warn you. If you click it, Melodyne will perform all the 

outstanding calculations and update the totality of the data.

Assignment File Load/Save (stand-alone implementation only): Melodyne can, if you wish, save 

your audio source as an assignment file containing such information as which algorithm was used for 

the source, the status of the algorithm parameters, and what editing was applied to the detection. The 

advantage of this is that it means the detection process does not have to be repeated each time the 

file is opened in Melodyne; furthermore, it means you only need to edit the detection and set the 

algorithm parameters once, as your work and settings will be restored automatically when the file is 

reopened. With the Save button, you can store such an assignment file alongside the edited audio 

file; the Load button allows you to reopen the file, in order, for instance, to revert to the original state 

after an inadvertent change of algorithm.

The Main Tool in Note Assignment Mode

In Note Assignment Mode, the toolbox contains tools with functions other than those used in normal 

Edit mode. The most important difference is this: In Note Assignment Mode, the tools have no direct 

or immediate impact on the sound of the notes; their object, rather, is to bring the detected and 

displayed notes as closely as possible into line with the actual music. This makes it possible 

subsequently to edit the material more efficiently and obtain optimal acoustic results.

Which tools are available depends upon the algorithm, as, to a lesser extent, do their functions.

The Main Tool in Note Assignment Mode combines important functions of the other tools, as it does in 

normal editing mode, so that you can perform a variety of common tasks without changing tools.

In the lower part of a blob, the Main Tool functions as the .Activation Tool

In the upper part of a blob, the Main Tool functions as the .Note Separation Tool

We will deal with each of these in turn.

The Activation Tool

The Activation Tool has no function when the Percussive and Universal algorithms are selected.
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If you click on a note with the Activation Tool, its overtone series is shown in the editing background. 

This enables you to recognize at a glance the octaves and other harmonic ratios of the displayed 

notes.

The Melodic Algorithm: Double-clicking on a blob instructs Melodyne to remove the note in question 

to the next most plausible pitch, if there is one. Particularly plausible alternative pitches are denoted 

by hollow blobs – so-called “potential notes” – and tend to lie an octave above or below the original 

blob. You can also double-click directly on one of these potential notes in order to activate it and 

deactivate the original blob. If Melodyne is unable to find a plausible alternative to the blob you have 

double-clicked, it leaves it where it is.

Dragging the blobs vertically with this tool has much the same effect: It instructs Melodyne to search 

higher up or further down for an alternative pitch. If a plausible pitch is found in the direction indicated, 

the blob snaps to it; otherwise it returns to its original position. You will use these double-clicking or 

dragging techniques to correct occasional octave errors in the detection.
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Starting point lines and designated starting points

If, in Note Assignment Mode, you select one of the separation tools, vertical lines appear in the Note 

Editor. At the same time, a slider with two indicators appears next to the toolbox.

We call the vertical lines “starting point lines”. Rising in parallel from their respective blobs to the Time 

Ruler, they show the  that Melodyne has identified in the audio file. A musical starting points

“designated starting point” is indicated by a short vertical line (a “vertical”) topped by an inverted 

triangle and is invariably found near the start of a blob (though not necessarily at its leftmost 

extremity); when active, it indicates what, for the purposes of timing, Melodyne considers to be the 

effective musical starting point of the note. The musical starting point may, but does not necessarily 

have to, be aligned with the separator at the beginning of the note. Think of a brass instrument, for 

example, where each note is often heralded by a certain amount of wind noise. This noise also 

belongs to the note, so it falls to the right of the note separator. What is relevant from the standpoint 

of timing, however – as is the case also with quantization – is the moment when the sound really 

unfolds and the pitch first becomes discernible;  is the timing-critical moment, and it is that later that

instant that is designated the musical starting point. If Melodyne is unable to pinpoint the musical 

starting point of a note, no starting point line is displayed and the note has no designated starting 

point. For the purposes of quantization, the leftmost extremity of the note is then considered to be the 

starting point.

Each of the longer, starting point lines also culminates in an inverted triangular indicator, which you 

will see just below the Time Ruler. This indicator can be solid, in which case the corresponding 

starting point line is visible and active; or it can be hollow, in which case the line is invisible: we call it 

in this case a “potential” or “inactive” starting point line. An inactive starting point line invariably 

coincides with the beginning of a note. For the note in question, however, Melodyne has been unable 

to discern with sufficient confidence a musically relevant starting point; it is for this reason that the 
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starting point line is only a potential one and that no vertical (no designated starting point indicator) is 

displayed at the blob.

The two slider indicators, the Parenthesis and the Ball, govern, respectively, how sensitive Melodyne 

is to the presence of potential starting points and how willing it is to activate them, the result being 

reflected in turn by the total number of triangles displayed and the percentage of these that are solid 

red. As you move the Parenthesis gradually to the right, more and more hollow triangles (indicating 

the presence of “potential” starting points) appear beneath the Time Ruler; this reflects Melodyne’s 

increasing sensitivity that is allowing it to divine more and more points in the material at which a 

starting point  reside – “might” because the lines that are added remain invisible and do not (yet) might

have any effect upon the blobs.

You can alter this, however, with the slider’s second indicator: the Ball. As you move the Ball to the 

right, more and more of the previously invisible, “potential” starting point lines will become active; and 

directly below them, at the level of the blobs, designated starting points will appear at the same time.

You can activate a potential starting point line by double-clicking on the hollow triangular indicator 

beneath the Time Ruler and, conversely, deactivate an active line by double-clicking on the 

corresponding solid triangle. Double-clicking in a free place in the ruler generates a new starting point 

line.

By dragging its indicator, it is possible to move a starting point line forwards or backwards in time; 

this, however, will seldom be necessary, as Melodyne almost invariably identifies the ideal position. 

You may still wish, though, to do some fine-tuning. If, for the purposes of experiment, you move a 

starting point line from left to right, you will notice that as soon as you pass over the start of a blob, a 

vertical appears complete with inverted triangle (indicating the presence of a designated starting 

point) that follows the line for a while before disappearing as soon as the note begins to decay, as, 

clearly, it would be futile to look any further for the musical starting point.
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Starting point lines exhibit a kind of “magnetic” property seen not only when you move them but also 

when separating notes and designating starting points manually.

The Note Separation Tool and the Separation Type Tool

The Note Separation Tool and the Separation Type Tool (directly below it in the toolbar) are available 

with all algorithms and function in the same way as their counterparts in Edit Mode. You can set or 

remove note separations by double-clicking and also move them along the time axis. With the 

Separation Type Tool, you can toggle between hard and soft separations.

By contrast with normal editing mode: In Note Assignment Mode, the separation tools are not used to 

reshape the music but to edit the analysis or “detection”. The object is to ensure that the blobs 

represent as accurately as possible the actual music. Tip: To provide two or more notes of differing 

pitch with a soft separation, you can select “Convert Selection to Connected Sequence” from the 

context menu (see below).

Since the placing of note separations and the editing of starting points often go hand in hand, you can 

also edit starting points with the Note Separation Tool. Simply move the pointer into the vicinity of the 

triangular starting point markers near the Time Ruler and it changes appearance to resemble the 

Starting Point Tool.
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It is possible at any time to deactivate a designated starting point (i.e. withdraw the designation). A 

new starting point can only be designated if an active starting point line is present in a plausible place 

i.e. the left-hand end of a blob. Look for a moment at the starting point indicators: In the relevant 

place, a hollow triangle (indicating the presence of a potential starting point) will probably already be 

displayed. Double-click on the triangle to activate the starting point line.

If no potential starting point line has been identified at the desired position, using the slider near the 

toolbox you can cause additional potential starting point lines to appear: to do this, simply move the 

right-hand control element (the Parenthesis) further to the right.

Alternatively, by double-clicking on an empty area of the ruler at the level of the starting point 

markers, you can create a new starting point line and drag it into position with the mouse. When, with 

the Melodic, Percussive or Universal algorithms selected, you activate a potential starting point line or 

create a new starting point line, a note separation is automatically inserted near a note at the position 

in question.

Tip: When editing starting point lines, if ever you have the feeling that somewhere a note starting 

point exists but that it is not indicated even by a potential starting point line, scrubbing in the relevant 

area often makes it to easier to locate the exact position. At the position in question, a rather loud 

noise component will be audible. Where the noise is loudest, release the mouse button and double-

click to place a starting point line.

The context menu: When you select one of the note separation tools, a context menu appears in the 

Note Editor in which you will find the following commands:

Convert Selection to Connected Sequence: With this command, you can convert a selection 

comprising two or more adjacent notes between which there are hard separations into a 

connected sequence with soft separations. This is also possible with notes differing in pitch 

and allows you gather together melodic lines to make more coherent editing possible later.

Separate Note: This command separates notes automatically at a point determined by 

Melodyne. It is useful when you need to make precise cuts in a vocal passage and isolate 

sibilants or breathing noise prior to editing using the tools.
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Reseparate Notes at Starting Point Lines: This command splits the selected notes at all active 

starting point lines passing through them. It offers you, therefore, a convenient way of inserting 

separations at the same point in multiple notes simultaneously, while removing any 

superfluous separations found elsewhere.

Separate Notes as Trill: The effect of this command is to slice a selection of one or more notes 

into smaller segments determined by the instantaneous pitch of each note. This is done by 

inserting note separations into the slopes of the pitch curve as it rises and falls, thereby turning 

each ‘hill’ and each ‘valley’ of a vibrato into a separate note.

Please note that the fluctuations in the Pitch Curve must be fairly pronounced for the “Separate Notes 

as Trill” function to have any effect and that it is only available when the Melodic algorithm is active, 

being grayed out in every other case. If you wish to assign a shortcut to the command “Separate 

Notes as Trill”, this can be done using the Preferences dialog.

Reset Separations Based on the Selected Grid: This command separates the notes at obvious 

starting points as well as at suitable positions on the selected Time Grid. This command is 

available with the Melodic, Percussive and Universal

algorithms.

The Starting Point Tool

The Starting Point Tool is the second sub-tool of the Note Separation Tool.

It is available with all algorithms and is used to designate or undesignate starting points manually by 

double-clicking. This tool function is also available in Note Assignment Mode by checking the 

corresponding option in the Note Inspector. A designated starting point is indicated by a vertical (i.e. a 

short vertical line) with a red triangle on top located at or near the leftmost extremity of the blob.
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By moving the Starting Point Tool in the region of the starting point markers beneath the Time Ruler, 

you can also edit these with the Starting Point Tool. As a rule, however, you will generally use the 

Note Separation Tool for this purpose, as described above.

The Note Inspector

As is the case in normal edit mode, the Note Inspector in Note Assignment Mode governs the 

selected notes – only here, different parameters are on view.

Pitch: The three fields correspond to those in edit mode and display i) the nearest note of the 

chromatic scale, ii) the deviation (if any) in cents from it, and iii) the equivalent frequency in hertz. It is 

not possible to input values into these fields but their content is updated whenever a blob is assigned 

to a different pitch (e.g. to correct an octave error).  The status of this field is Hard separation:

determined either by changes made with the Separation Type Tool or by checking/clearing the box. 

You can only check this box if there is currently a soft separation between the selected note and an 

adjacent one.

Starting Point: The status of this field is determined either by changes made with the Starting Point 

Tool or by checking/clearing the box. Here, just as with the corresponding tool, you can attach the 

selected note to a starting point line or detach it from it.
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The Time Grid

The Time Grid slices up the time axis at regular intervals to provide a clearer temporal overview. It 

can also have the function, however, of causing content as it is moved to snap to the nearest grid 

line, thereby making it easier to position notes exactly on the beat. For the spacing of the grid (i.e. the 

distance between adjacent grid lines), you can choose between Seconds and any of a variety of note 

values (half note, quarter note etc.).

Activating and setting the Time Grid

To adjust the Time Grid, either choose Options > Time Grid from the main menu or click the note icon 

(at the top right of the Note Editor) to open the pop-up menu shown here.

Clicking on the note icon activates or deactivates the grid; you can also define a keyboard shortcut for 

this command from the Shortcuts page of the Preferences dialog. If you click the note value or the 

arrow alongside it and hold down the mouse button, the grid menu pops up.

This allows you to the set the interval between grid lines to any of a variety of regular or triplet note 

values or else to Seconds.
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The time axis is then graduated at intervals equivalent to the note value selected. If you have chosen 

a small note value (such as 1/16) and then zoom the display outwards, at a certain point it will 

become impossible to display all the grid lines; the grid value selected, however, will remain active.

Moving notes when the grid is active

When the Time Grid is active and Seconds is not checked, notes moved from one beat to another will 

end up the same distance from the new beat as they were from the old one. In other words, whilst the 

grid does influence their position, they don’t snap exactly to the nearest grid line unless they were on 

a grid line to begin with. The note depicted below, for example, sounds slightly after the first beat of 

the bar.

If, while the grid is active, this is moved to the second beat, there, too, it will sound slightly after the 

beat – the offset in the two cases being identical.

Even if the grid is active, you can still adjust the position of a note (or a selection of notes) 

independently of the grid by holding down the [Alt] key as you move it.
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Pitch Grid and scales

You can shift the pitch of notes in Melodyne either continuously or in discrete steps using the grid. 

When the grid is active, notes can only be moved to such pitches as the grid allows. The grid in such 

cases can correspond to either the chromatic or some other scale.

The functions of the Pitch Ruler and access to the Pitch Grid

You can change the options relating to the Pitch Grid either from the sub-menu of the same name 

under Options in the main menu or by clicking the clef icon directly above the Pitch Ruler.

Activating the Pitch Grid and selecting display options

Single-clicking the clef icon activates or deactivates the Pitch Grid, thereby switching on and off the 

snap function. When the grid is inactive, you can move notes freely in pitch – even to frequencies 

falling between notes of the chromatic scale. The Pitch Ruler in this case displays, for reference only, 

faint lines between the notes.

If you click the clef icon or the small arrow symbol alongside it, hold down the mouse button and drag 

downwards, a drop-down menu opens displaying the snap, background and ruler options:

Snap

No Snap: The grid is inactive. Notes can be moved to any pitch, whether or not it coincides 

with a degree of the chromatic scale.

Chromatic Snap: Notes snap to the nearest degree of the chromatic scale and the lines on the 

Pitch Ruler are more boldly displayed.
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Scale Snap: In this case, based on its own analysis of the audio material, Melodyne selects 

what it considers the most appropriate major or minor scale. The tonic (or ‘keynote’) thus 

ascertained is highlighted in the Pitch Ruler. Naturally you can alter the scale and tonic but we 

will come to that in a moment. Let’s look first at the other options in this menu.

Background

Here you can choose the appearance of the background in the Note Editor.

Piano Keyboard: the darker beams in the Note Editor represent the black notes of a piano 

keyboard and the paler beams the white ones – a layout with which users of most MIDI editors 

will be familiar.

Scale Notes: The lighter beams are assigned to the notes of the scale, whilst the darker 

beams indicate notes foreign to it. When Scale Snap is selected, therefore, notes will 

invariably come to rest on the lighter beams.

Pitch Lines: The degrees of the scale are indicated by bold lines instead of beams – with 

thinner lines reserved for notes foreign to the scale. This is useful in the case of poor 

intonation, as the precise pitch of each degree of the scale is clearly indicated.

Ruler

Here you can choose whether the Pitch Ruler displays the names of the notes or the degrees of the 

scale.

The Scale Ruler and the Reference Pitch Ruler

To select a tonic (keynote) and a scale yourself or change other settings, open the drawer we 

mentioned earlier a little wider by clicking the rightmost arrow beneath the Pitch Ruler. Two new 

columns will appear to the left of it.
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Adjusting the master tuning

The narrow column on the very left is the Reference Pitch Ruler. Drag in either direction the mark 

alongside any note – A4, for example – and the Frequency Ruler appears, which you can consult as 

you fine-tune the note in question and, with it, of course, all the other notes of the scale. What you are 

doing here is adjusting the master tuning for the entire Pitch Grid. A tip: increase the vertical zoom 

factor, as this will make it easier for you to locate the value you want.

By right-clicking any of the marks on the ruler, you can open a small context menu. This offers a 

number of pointers to help you bring the Pitch Grid swiftly into line with a particular tuning:
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At the top, you will see the current frequency of the note selected.

Concert: bases the tuning on modern standard concert pitch (where A4 = 440 Hz).

Default: bases the tuning on the frequency currently assigned to A4 in the Preferences dialog.

Detected: bases the tuning on Melodyne’s analysis of the music being edited – the original 

tuning.

Set as Default: tells Melodyne to use the current value as the default tuning for new 

documents and adjusts the value in the Preferences dialog accordingly.

The various settings for A4, incidentally, can be found quickly by clicking the tuning fork icon at the 

top of the Reference Pitch Ruler. By typing into the box immediately below this icon, you can assign 

to A4 any frequency you like.

Selecting the tonic and scale variety

The wider ruler next to the Reference Pitch Ruler is the Scale Ruler. Here you can select the ‘tonic’ (i.

e. the first degree or keynote) of the scale as well as its mode or type. First click on the note you wish 

to use as the tonic. The following menu opens:
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Related scales: in the top part of the menu, you will find a varying number of scales preceded by a “=” 

sign. These are scales that correspond to the current scale but are differently named.

Please note that when you select a related scale from this menu, only the main structure of the mode 

in question is adopted: the scale is simply given a new name and, if applicable, a new tonic. It can be, 

however, that the exact definition of the related scale in question contains additional secondary 

degrees or fine-tuning. If you wish to use these, please choose Open Scale... from the scale drop-

down menu.

The current note: in the middle of the submenu, grayed out, you will see the name of the note 

you have clicked on and which you can now make the tonic.

Major / Minor: Allows you to select a major or minor scale with the note selected as tonic. To 

select C Major, for example, click C in the ruler, followed by C Major from the submenu.

Open Scale... : opens Melodyne’s Scale Window, which offers access to a wide variety of 

additional scales. This window will be described in the next section.

Analyzed: this offers you rapid access to two options derived from Melodyne’s analysis of the 

material: the closest major or minor scales and an exact microtonal scale.

Notes Reflect Scale Changes: normally when you change the scale, Melodyne adjusts the 

Pitch Grid but does not change the notes themselves unless you double-click on them first, in 

which case they will snap to the grid. If, however, you wish the notes to adjust automatically to 

any change of scale, select either Tuning or Tuning and Mode. Then any changes will take 

effect immediately and you will hear them at once during playback.

Play Scale: plays the current scale. When this function is active, the loudspeaker icon appears 

above the Scale Ruler. By clicking on this icon, you can deactivate the function without 

needing to access a menu.
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Tip: Initialize the key prior to the transfer/load: In the case of monophonic or polyphonic audio 

material, Melodyne also recognizes the key of the music. With short melodic phrases, however, the 

key chosen is often not the one intended, simply because too few notes are available for a correct 

appraisal. To prevent this happening, you can set the key using the Scale Ruler of an empty instance 

of the plug-in or an empty document (if using the stand-alone implementation of the program)  before

the transfer or loading of an audio file. To do this, simply click on the desired keynote in the Scale 

Ruler and select the desired scale from the context menu. Melodyne will then retain this initialized 

value, regardless of its own subsequent analysis.

The Scale Window

Melodyne’s Scale Window offers a multitude of scales you can select, listen to, and make use of. To 

access this window, choose “Open Scale” from the context menu of the Scale Ruler.

The selected scale applies to all instances of the Melodyne plug-in.

To open the Scale Window, select Open Scale from the context menu of the Scale Ruler.
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Now choose a category from the left-hand pane followed by the desired scale from the pane on the 

right. Click the loudspeaker icon to the right of each entry to hear the scale selected.

If you have activated the option Notes Follow Scale Changes, during playback you will hear 

immediately the effect of applying the scale selected to your audio material. The window allows you to 

try out (or ‘audition’) different scales quickly and easily. If you wish to adopt the changes, exit the 

window with OK; otherwise click Cancel.

From the lower pane of the window, you can select between the parameters of your existing scale 

and those of the scale selected in the Scale Window.

Mode and Tuning: you can adopt either the parameters of your existing scale (on the left) or of 

the scale currently selected in the Scale Window (on the right).

Tonic: you can choose between the selected tonic or the tonic from the preset.

Pitch: here you can choose between current tuning, the pitch from the preset or various 

standard tunings.

Stretching: here you can select whether or not stretched tuning should be applied to the scale.

External Scales Folder...: this button allows you to open a folder containing scale definitions in 

Scala format (filename extension “.scl”) which will then appear as an additional category in the 

Scale Window.

On the Internet, you will find at http://www.huygens-fokker.org/microtonality/scales.html a collection of 

over 4,000 Scala files that you can copy to any part of your hard disk and audition and try out in this 

way using Melodyne editor.

You can also load scale definitions created in Melodyne studio (filename extension ‘.mts’) with this 

button.
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Selecting notes

In this tour, you will learn which techniques you can use to select notes in Melodyne prior to editing 

them.

Standard selection techniques

Click a note in the Note Editor to select it. Selected notes are more boldly colored.

[Command]-click additional notes to add them to the selection.

[Command]-clicking a selected note removes it from the selection.

 

Another way of selecting multiple blobs is to lasso them by clicking the background in one corner of 

the desired selection and then dragging the pointer to the corner diagonally opposite. This is 

sometimes called rubber-banding. If you hold down the [Command] key, you can add a further rubber-

band selection to the existing one. You can also add individual notes to the selection (or remove them 

from it) by [Command]-clicking.

To select a passage (i.e. a series of notes), click the first note of the series and then [Shift]-click the 

last (or vice versa).
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Snake selection

If you press the [Shift] key, click a note and then move the mouse pointer away, Melodyne’s snake 

selection mode is activated.  You can now add notes to the selection by painting over them with the 

snake.

If you move the mouse (and thereby the snake) backwards again, you can remove notes previously 

painted over from the selection.

Selection using the Pitch Ruler

Click a note in the Pitch Ruler to select notes of the corresponding pitch.

If cycle mode is active, the selection only affects such notes if they lie within the cycle range.

http://helpcenter.celemony.com/hc-2/?lang=en&startPageEdition=melodyne-assistant
http://www.celemony.com


Melodyne 4 assistant - Stand-alone

   © Celemony Software GmbH 2020 • Last updated on 12/07/2020 • Help Center • www.celemony.com 67

By [Command]-clicking other notes in the Pitch Ruler, you can add them to the selection and later 

remove them by the same means.

If you double-click, as opposed to single-clicking, a note in the Pitch Ruler, you will select the same 

note in all octaves rather than simply that single instance of the note.

Click and drag in the Pitch Ruler to select a range of notes.

By using the [Command] key in the Pitch Ruler, you can remove from the selection a range of notes 

or individual notes. Here too, if a cycle is active, only notes within the cycle range will be selected.

Selection commands in the menu

In the Edit menu and the context menu of the Note Editor, you will find the command Select All and 

the Select Special sub-menu, which contains a number of more sophisticated options.

The command Restore Last Selection reverses the last selection step, thereby restoring the selection 

that was active beforehand. This is useful if you are in the process of performing a complex selection 

and accidentally shoot astray, causing the selection to disappear. By clicking Restore Last Selection, 

you can retrieve it.

The command Invert Note Selection deselects all selected notes and selects all notes that were 

previously not selected. The commands that follow are similarly self-explanatory, allowing you to 

select all the notes that follow, all notes of the same pitch, all notes of the same pitch in all octaves, 

and so on.

The command Select Fifths Above and Below in All Octaves selects tones a fifth above and below the 

selected tones in all octaves. All the Select commands in the second subdivision of the menu operate 

on the cycle zone only if cycle mode is active.

The two commands that follow, Select Same Beat in All Bars and Select Notes Between Locators, are 

also self-explanatory.

http://helpcenter.celemony.com/hc-2/?lang=en&startPageEdition=melodyne-assistant
http://www.celemony.com


Melodyne 4 assistant - Stand-alone

   © Celemony Software GmbH 2020 • Last updated on 12/07/2020 • Help Center • www.celemony.com 68

Correct Pitch Macro

The Correct Pitch Macro is used to rectify poor intonation quickly and intelligently and rein in any 

undue wavering in pitch. 

Opening and using the macro

Select the notes you wish to edit. If no notes are selected, macro editing will by default affect all notes.

To open the macro, choose Edit > Quantization Macros > Correct Pitch or click on this button at the 

top of the Note Editor.

Here, with the upper slider, you can apply a degree of correction ranging in intensity from 0% (no 

influence) to 100% (full power) to the pitch center of the notes selected. By default, such notes are 

moved towards, or to, the nearest semitone, but if you check the option “Snap to (the selected 

scale)”, notes foreign to the scale will be ignored as possible destinations, and, depending upon the 

position of the slider, notes will move a certain distance towards, or all the way to, the nearest degree 

of the scale in question.

A word of caution here: notes often fluctuate slightly in pitch, so their position is based on a mean 

pitch that Melodyne has to calculate. This mean pitch, or “pitch center”, forms the basis for pitch 

correction. If a note wavers slightly in pitch, it cannot be guaranteed that, after 100% correction has 

been applied to it, it will sound right at the new pitch – especially since the correct pitch of any given 

note is not a constant but depends upon the musical context. 

The macro works in a musically intelligent manner: At lower settings it affects only those notes that 

are wildly out of tune, leaving untouched those that are already quite close to the intended pitch. As 

the slider is moved further towards the right, however, even those notes are influenced, and to an 

increasing degree, until at 100% all the selected notes are exactly in tune.

The pitch center, which the macro adjusts automatically, is the same parameter that is modified when 

pitch correction is performed manually using the Pitch Tool.
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With the lower slider, you can progressively reduce the amount of pitch drift exhibited by the notes in 

question. By “pitch drift”, we mean the kind of slow wavering in pitch that is symptomatic of poor 

technique. More rapid fluctuations in pitch, such as pitch modulation or vibrato, remain unaffected.

You can modify both correction parameters in real time as the audio plays back; and hear, but also 

see (by the movement of the blobs in the Note Editor, the effect of different settings.

If you have already fine-tuned some notes using the Pitch Tool, Melodyne will assume you 

are satisfied with the results; this means that, by default, if you now open the Correct Pitch Macro with 

no notes selected and begin making changes, only the other notes will be affected. By default, in 

other words, notes that have been tuned manually are not affected by the macro. If you wish the pitch 

of these too to be affected by the macro, check ‘Include notes fine-tuned manually’. The option is 

grayed out, of course, as being of no relevance, if no manual editing of intonation has been 

performed.

Closing the macro and correction values when it is reopened

Exit with OK to keep your changes or Cancel to discard them. Naturally the fact that you have used 

the Correct Pitch Macro in no way precludes your fine-tuning notes at any time subsequently by hand.

If you select a note that has already been edited using the macro and then open the macro again, the 

settings previously applied to it will be displayed; the macro remembers, in other words, the 

parameters previously applied to each note. If the current selection includes notes to which different 

settings have been applied, when it is opened the minimum and maximum values for each parameter 

will be displayed.

Even after exiting with OK, you can still reverse the effects of the macro editing by using the undo 

function. 
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Quantize Time Macro

In this tour, you will learn how to work with the Quantize Time Macro, which makes it possible to 

correct the timing of notes swiftly and effortlessly.

Quantizing timing: What is moved and where to?

Before examining the operation of the Quantize Time Macro, we should clarify a few basic concepts 

and relationships.

To understand these better, let’s begin by selecting the Time Tool. When this is active, a note 

separation (indicated by a vertical dash) or the musical starting point of the note (indicated by a 

vertical dash with a triangle) appears near the start of each blob.

Now check Show Intended Notes in the Options > Note Editor sub-menu, which can also be 

accessed via the cog icon in the top right-hand corner of the Note Editor.

Gray boxes now enclose each blob.

When it first analyzes the material, Melodyne calculates for each note two parameters of relevance to 

the process of time correction.

The first is the intended musical beat of the note; this is indicated by the start of the gray frame 

enclosing the blob. As you can see, the start of the frame invariably coincides with a grid line.
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The second is the the beginning or musical starting point of the note, represented, respectively, by a 

note separation or a vertical dash with a triangle. This will not necessarily be aligned with the left-

hand extremity of the blob. Think of a brass instrument, for example, where each actual note is often 

heralded by a certain amount of wind noise. Admittedly this noise belongs to the note, but from the 

standpoint of timing what is of relevance is the moment the sound really unfolds and the pitch first 

becomes discernible; that is the timing-critical moment.

It may not always be possible to determine when this occurs, in which case only the beginning of the 

note will be marked. (Starting points can be edited in Note Assignment Mode).

If you quantize notes with the Quantize Time Macro, the musical starting point of each note (if one 

has been determined; if not, the beginning of the note] will move towards the left-hand side of its gray 

frame. The quantization intensity slider determines whether it goes all of the way, or only part of the 

way, to the beat assigned it.

Opening the Quantize Time Macro and setting the parameters

Select the notes you wish to edit. If no notes are selected, macro editing will by default affect all 

notes. 

To open the Quantize Time Macro, choose Edit > Quantization Macros > Quantize Time or click the 

Quantize Time icon (illustrated here) to the right of the toolbar in the Note Editor.

First, the Groove Reference (if any) that will govern the time correction must be selected.

If Auto is selected, the target (or ultimate destination) of any quantization will be the left-hand edge of 

the gray frame, as already described. This is invariably aligned with the grid line that represents the 

beat to which Melodyne, in the course of its analysis, assigned the note. (On the whole, the system 

functions very well; but it can happen that Melodyne gets it wrong, and that after 

quantization you have to move the note manually to the preceding or following beat.) By selecting 
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Auto, in other words, you are telling the Quantize Time Macro to move notes to (or towards) the beats 

assigned them by Melodyne based on its own analysis of the material.

With the other buttons, you can select the target grid for the quantization. The ‘T’ next to the note 

values stands for the corresponding triplet. If you select 1/4 as the Groove Reference, to give one 

example, the grey frames will move to the nearest quarter-note (or ‘crotchet’) and this will then 

become the ultimate destination for any quantization.

Note that the time correction macro works differently from, and in a more musical fashion than, the 

quantization typically offered by MIDI sequencers. Instead of simply causing all notes to snap to the 

selected grid, it edits the points of rhythmic emphasis of the selected notes. If, for example, you take 

a passage containing successions of sixteenth notes (semiquavers) and quantize it to quarter notes

(crotchets), the beginning of each succession of sixteenth notes will be moved to the nearest quarter 

note. The timing of the semiquavers within the sequence, however, remains unaltered. If you wish to 

tidy that up as well, you can do so in a second pass, taking each semiquaver sequence in turn and 

using sixteenth notes as the quantization factor.

The Intensity slider determines what percentage of the distance to this ultimate destination the notes 

will travel in the course of quantization. If you select 0%, for example, they’ll not budge; 50%, and 

they’ll go half way; 100%, and they’ll travel the full distance, ending up precisely on the beat. You can 

modify both the Groove Reference and the Intensity of the quantization in real time as the audio plays 

back; and hear, but also see (from the movement of the blobs in the Note Editor), the effect of 

different settings.

If you have already finely adjusted the position of notes using the Timing Tool, Melodyne will assume 

you are satisfied with the results; this means that, by default, if you now open the Quantize Time 

Macro with no notes selected and begin making changes, all notes will be affected except these. If 

you wish the position of these too to be affected by the macro, check ‘Include notes fine-tuned 

manually’. The option is grayed out, of course, as being of no relevance, if no manual editing of note 

positions has been performed.
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Closing the macro and correction values on reopening

Exit with OK to keep your changes or Cancel to discard them. Naturally, the fact that you have used 

the Quantize Time Macro in no way precludes your moving notes at any time subsequently by hand.

If you select a note that has already been edited using the macro and then open the macro again, the 

settings previously applied to it will be displayed; the macro remembers, in other words, the 

parameters previously applied to each note. If the current selection includes notes to which different 

settings have been applied, a mean value for each parameter will be displayed. 

Even after exiting with OK, you can still reverse the effects of the macro editing by using the undo 

function.
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Main Tool

Melodyne’s Main Tool is context-sensitive, its exact function at any given moment depending upon its 

position relative to the selected blob. It has no unique functions but simply offers a different mode of 

access to functions it shares with the more specialized tools for editing pitch, timing and note 

separations, combining them in such a way that you can perform the most essential editing tasks 

without ever having to change tools.

Modifying the pitch and timing of notes

Select the Main Tool (denoted by an arrow) from either the toolbox or the context menu of the Note 

Editor or by pressing the [F1] key of your computer keyboard. (If you wish to assign a different 

shortcut to this tool, you may do so after choosing Melodyne > Preferences > Shortcuts > Editing 

Tools from the main menu.)

With the Main Tool, move the arrow to a point near the center of a blob and press and hold the 

mouse button as you drag it upwards or downwards (to alter its pitch) or left or right (to move it 

forwards or backwards in time). It is the initial movement (whether vertical or horizontal) that decides 

whether the pitch or timing of the note is altered. Before changing axis, you must first release the 

note. If you hold down the [Alt] key as you drag the note, the Pitch Grid or Time Grid, even if active, 

will temporarily be ignored, allowing you to position the note exactly where you want it.

While you are dragging a note up or down, you will hear the frozen sound of the note at the point 

where you clicked. If, whilst dragging, you move the mouse to the right or left, you can put other parts 

of the note under the acoustic microscope. If you do not wish to monitor pitch changes in this way, 

uncheck the option Monitor When Editing Blobs in the Options > Note Editor sub-menu, which can 

also be accessed via the cog icon in the top right-hand corner of the Note Editor.
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Modifying note lengths

Open the Note Editor Options menu and check Show Blob Info. Zoom in on a few individual blobs, so 

that you can study them more closely. Now, as you move the mouse pointer over a blob, thin lines 

appear indicating the zones in which the Main Tool performs particular functions. For illustrative 

purposes, the lines here have been drawn more boldly than in the program itself. The central area 

you already know about. This has to be distinguished from the front, back and upper regions of the 

blob. As you move the mouse pointer from one of these regions to another, it changes its appearance 

to emulate whichever of the more specialized tools is most appropriate to that zone – adopting its 

functions at the same time.

Drag the front part of a note to the right or left. Hold down the [Alt] key as you do so if you wish to 

override an active time grid. Now only the beginning of the note moves; the end remains anchored, so 

the note is either being stretched or compressed.

In the same way, you can move only the rightmost part of the blob (corresponding to the end of the 

note).

Notice that as you move the beginning or end of a note in this way, the preceding or following note, if 

adjacent, is also either stretched or compressed by the same amount to avoid either the two notes 

overlapping or white space (silence) appearing between them. This type of relationship exists 

whenever a pitch transition between consecutive notes has been detected. By moving the adjacent 

note as well, Melodyne ensures that discontinuities are avoided and the musicality of the phrasing is 

preserved.

If this behavior is not what you want, you can change the ‘soft’ separation between the notes into a 

‘hard’ one using the Separation Type Tool. Instead of the separation line, a bracket will then appear 
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between the two notes to indicate that no further connection exists between them. You will find the 

Separation Type Tool beneath the Note Separation Tool in the toolbar.

Editing note separations

If you move the mouse pointer to the upper part of a note (above the horizontal line), the Main Tool 

adopts the appearance, and emulates the functions, of the Note Separation Tool. If you double-click 

now, you can create a note separation – i.e. slice the note in two.

Don’t be surprised if the two notes that result move apart in pitch: this is because a new tonal center 

is calculated for each of the newly created notes, and that may differ from the tonal center they 

shared when they were one note. In such cases, each therefore moves to a new vertical position 

based on its newly calculated pitch center.

You can move an existing note separation horizontally with the Note Separation Tool. Before you 

begin, choose Options > Note Editor Options and check Show Note Separations.

You can double-click a note separation to remove it.

If you select several notes and move a note separation, the note separations of the other selected 

notes will also be moved. If you double-click one of the note separations to remove it, those of the 

other selected notes will also be removed.

If you have selected several notes that overlap, you can simultaneously insert a note separation at 

the same point in all of them, as well as move or remove one.
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Pitch Tool

The Pitch Tool edits the central emphasis of the pitch of each note. This is the ‘pitch center’ note 

parameter that can also be edited using Melodyne’s Main Tool.

Shifting the pitch center

Select the Pitch Tool from either the toolbox or the context menu of the Note Editor or by pressing the 

[F2] key of your computer keyboard. (If you wish to assign a different shortcut to this tool, you may do 

so after choosing Melodyne > Preferences > Shortcuts > Editing Tools from the main menu.)

The Pitch Tool is the topmost of the three pitch editing tools. It is responsible for the pitch center of 

each note, which can be thought of as its center of gravity. Melodyne allows you to edit the pitch 

center of notes independently of any modulation or drifting in pitch they exhibit. Press the [F2] key 

twice and three times in quick succession to select, respectively, the first and second sub-tools of the 

Pitch Tool. From the Preferences dialog, you can also, if you wish, define separate keyboard 

shortcuts for all three tools.

Drag a note up or down with the Pitch Tool to alter its pitch. If the note is one of several selected, all 

the notes in the selection will move up or down en bloc.

Depending upon whether No Snap, Chromatic Snap or Scale Snap is selected, notes can either be 

moved freely or will snap to the nearest semitone or note of the selected scale.

Hold down the [Alt] key as you move notes if you wish the selected grid to be ignored; this will allow 

you to position the note freely.
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Monitoring pitch shifts

As you move a note in pitch, you will hear the ‘frozen’ sound of the note at the position clicked. By 

moving the mouse to the left or right whilst doing so, you can put other parts of the note under the 

acoustic microscope. If you do not wish to monitor pitch changes in this way, uncheck the option 

Monitor When Editing Blobs in the Options > Note Editor sub-menu, which can also be accessed via 

the cog icon in the top right-hand corner of the Note Editor.

If several notes sound simultaneously at that point, you can hear not only the note being moved but 

also its harmonic context, which is very useful if, for example, you wish to construct chords. To do 

this, press and hold the [Command] key once you have begun to move the note and you will hear the 

frozen sound of all the notes of the chord at the position in question.

Editing pitch with the inspectors

As an alternative to editing the selected notes with the Pitch Tool, you can enter the desired value for 

the note and the deviation in cents from equal temperament in the inspector near the toolbar or the 

Note Inspector. The Note Inspector also allows you to determine the frequency in hertz of the note or 

notes selected. In each case you can increase or decrease the current value by clicking in the 

relevant box and dragging the arrow upwards or downwards.

When typing values into the Pitch field, you can enter either absolute values (C3, D4 etc.) or relative 

ones (+2, -1, etc.).

If you have selected several notes that differ in pitch, three hyphens are displayed in the boxes – 

followed, as you click in the box and drag, by values describing the extent of the relative change.

Correcting pitch with a double click

You can see that a note is sharp or flat from the fact that it doesn’t lie plumb in the middle of any of 

the horizontal lanes in the editing display. These represent the notes of the chromatic scale, the note 

in question, in each case, being indicated by the vertical Pitch Ruler to the left of the Note Editor. If, 

with the Pitch Tool selected, you now double-click the offending note, it – and any other notes 

selected at the same time – will ‘snap to the grid’, which means each will move instantly to the very 

center of the lane representing the semitone nearest to it in pitch.
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A word of caution here: notes often fluctuate slightly in pitch, so their position is based on a mean 

pitch that Melodyne has to calculate. This value, which we call their pitch center, forms the basis for 

any pitch quantization. If a note fluctuates slightly in pitch, it cannot be guaranteed that after snapping 

directly to the nearest semitone during quantization it will sound ‘right’ at the new pitch – especially 

since ‘correct pitch’ is not an absolute, but something that depends at all times upon the musical 

context.

Pitch transitions

When one note follows another and a tonal relationship between the pair has been detected, the pitch 

curve is drawn through them, and in the area between them a thick orange line is displayed that 

represents the pitch transition.

If you position the Pitch Tool over the rear part of a note, click and drag vertically, you can make the 

pitch transition steeper or less steep.

Pitch transitions only exist between adjacent notes between which there is a soft separation. By 

clicking on a soft separation with the Separation Type Tool (the sub-tool of the Note Separation Tool), 

you can transform it into a hard separation, thereby deactivating all association between the two 

notes and with it the pitch transition.
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Resetting individual edits and introducing random deviations

In the Edit > Reset Individual Edits > Pitch cascading menu, you will find a variety of commands that 

can be used to reverse the effects of particular types of pitch editing, thereby restoring specific 

aspects of the notes selected to their original state. The commands apply only to the current selection 

and are grayed out whenever no editing of the type in question has yet been applied to the notes 

concerned. Note that these commands operate entirely independently of the normal undo function!

With the commands in the Edit > Add Random Deviations sub-menu, you can randomly alter the pitch 

of the notes currently selected – introducing either slight, moderate or drastic deviations from the 

original intonation. You can also employ the commands several times in succession to intensify the 

effect. These commands are useful when, for example, you’ve doubled a track in order to obtain a 

fuller or ‘fatter’ sound. By introducing random deviations, so that the copy is no longer identical to the 

original, you can simulate more realistically the effect of two performers playing or singing in unison. 

All these commands affect only the selected notes and are therefore grayed out if no notes are 

selected.
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Pitch modulation and drift

The term ‘pitch modulation’ covers rapid and usually intentional variations in pitch such as trills or 

vibrato. ‘Pitch drift’ is our term for slow fluctuations in pitch of the kind that are usually unintentional 

and symptomatic of poor technique. You will find the tools for editing these parameters beneath the 

Pitch Tool in the toolbar.

Editing pitch modulation and drift

Select the Pitch Modulation or the Pitch Drift Tool from either the toolbox or the context menu of the 

Note Editor or by pressing the [F2] key of your computer keyboard.

The Pitch Modulation Tool is the first, and the Pitch Drift Tool the second, sub-tool of the Pitch Tool. 

Press the [F2] key twice in quick succession to select the former and three times in quick succession 

for the latter. (If you wish to assign a different shortcut to this tool, you may do so after choosing 

Melodyne > Preferences > Shortcuts > Editing Tools from the main menu.) There, if you wish, you 

can also define separate keyboard shortcuts for all three tools.

With the tool selected, click on a note and – without releasing the mouse button – drag up or down. 

The note edited could be part of a multiple selection, in which case you will be editing all the selected 

notes simultaneously. Watch as the pitch curve changes shape.

Drag far enough downwards and the modulation or drift are reduced to zero and then inverted.
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If you double-click a note with the Pitch Modulation Tool or the Pitch Drift Tool, you will restore the 

pitch modulation or drift of the original recording, assuming you’ve changed it, otherwise eliminate it 

altogether. Subsequent double-clicking toggles between the original modulation or drift and none. If 

you eliminate altogether both the modulation and the drift, you will get an unnaturally flat monotone 

that can be suitable for effects.

The inspector for pitch modulation and drift

As an alternative to editing selected notes with these tools, you can enter the desired values in the 

inspector alongside the toolbar or in the Note Inspector. Drag the existing value to change it or double-

click on it and type in the value desired.

With the Pitch Modulation Tool or the Pitch Drift Tool selected, the inspector displays values in 

percentage terms. 100% represents in this case the original modulation or drift, 0% a straight line, 

and -100% the same curve inverted with its axis unchanged. If you have selected several notes with 

different values, a dash is displayed in the box – followed, as you click in the box and drag, by values 

describing the extent of the relative change.

The Reset commands

In the Edit > Reset Individual Edits > Pitch cascading menu, you will find a variety of commands that 

can be used to reverse the effects of particular types of pitch editing, thereby restoring the notes 

selected in specific respects to their original state. These commands relate always to the current 

selection and are grayed out if no editing of the type in question has been applied to the selected 

notes. Note that these commands operate independently of the normal undo function.
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Formant Tool

Formants are areas of emphasis or attenuation in the frequency spectrum of a sound that are 

independent of the pitch of the fundamental note but are found always in the same frequency ranges. 

They are characteristic of the tone color or ‘timbre’ of each sound source, and interesting effects can 

be produced by shifting them, such as making a man’s voice sound like that of a woman, and vice 

versa.

Shifting formants

Select the Formant Tool from either the toolbox or the context menu of the Note Editor or by pressing 

the [F3] key of your computer keyboard. (If you wish to assign a different shortcut to this tool, you 

may do so after choosing Melodyne > Preferences > Shortcuts > Editing Tools from the main menu.) 

A beam appears over the blobs indicating the extent (if any) to which the formants have been 

transposed from their original pitches.

With the tool selected, click on a note and – without releasing the mouse button – drag the mouse up 

or down. As you do so, the formants will be transposed upwards or downwards, the degree and 

direction of the movement being indicated by a corresponding vertical movement of the beam.
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The beams indicate the distance in cents (100 cents = 1 semitone) by which the formants have been 

transposed upwards or downwards. You can shift the formants a few cents (for the finest of nuances) 

or several thousand (for a drastic denaturing of the sound). Double-clicking on a note with the 

Formant Tool restores its formants (as well as those of any other notes selected) to their original 

pitches.

The inspector for the formants

As an alternative to editing selected notes with the tool, you can enter the desired values in the 

inspector, which you will find alongside the toolbox or in the Note Inspector. Drag the existing value to 

change it, or double-click on it and type in the value desired.

If you have selected several notes that differ in the amount of formant shifting that has been applied 

to them, a dash is displayed – followed, as you click in the box and drag, by values describing the 

extent of the relative change.

Formant transitions

A thick orange line appears between the formant beams of adjacent notes as soon as you shift the 

formants of one note more, or in a different direction, than those of the other. This line represents the 

formant transition between the two notes.
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If you move the Formant Tool to the end of the first note, it changes into the Formant Transitions 

Tool. Dragging vertically with this tool governs the speed of the formant transition, which is indicated 

by the steepness of the connecting line.

Formant transitions only exist in the case of adjacent notes between which there is a soft note 

separation. If you transform this into a hard note separation by double-clicking with the Note 

Separation Type Tool (the sub-tool of the Note Separation Tool), all association between the notes 

will be severed and the formant transition between them deactivated.

The Reset commands

In the Edit > Reset Individual Edits > Formants cascading menu, you will find a pair of commands that 

can be used to reverse the effects of any shifting of formants or editing of formant transitions you may 

have performed, thereby restoring the notes selected in these respects to their original state. These 

commands relate always to the current selection and are grayed out if no editing of the type in 

question has been applied to the selected notes. Note that these commands operate independently of 

the normal undo function!
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Amplitude Tool

The Amplitude Tool allows you to adjust the amplitude (i.e. volume) of the selected notes, edit the 

amplitude transitions between them, and mute them.

Editing amplitude

Select the Amplitude Tool from either the toolbox or the context menu of the Note Editor or by 

pressing the [F4] key of your computer keyboard. (If you wish to assign a different shortcut to this 

tool, you may do so after choosing Melodyne > Preferences > Shortcuts > Editing Tools from the 

main menu.)

With the tool selected, click on a note (or one of several notes selected) and – without releasing the 

button – drag the mouse up or down. The vertical depth of the blobs will increase or decease as the 

notes they represent get louder or softer.

The gearing of the amplitude adjustment is dependent upon the vertical zoom resolution. Press and 

hold the [Alt] key, to switch to smaller increments for finer adjustment.

Editing amplitude using the inspectors

As an alternative to editing selected notes with the Amplitude Tool, you can enter the desired values 

in the inspector to the right of the toolbar or the Note Inspector. Drag the existing value to change it or 

double-click on it and type in the value desired. Press and hold the [Alt] key, to switch to smaller 

increments for finer adjustment.

http://helpcenter.celemony.com/hc-2/?lang=en&startPageEdition=melodyne-assistant
http://www.celemony.com


Melodyne 4 assistant - Stand-alone

   © Celemony Software GmbH 2020 • Last updated on 12/07/2020 • Help Center • www.celemony.com 87

If you have selected several notes to which different amplitude adjustment has been applied, a dash 

is displayed in the box – followed, as you click in the box and drag, by values describing the extent of 

the relative change.

Amplitude transitions

A thick orange line appears between connected notes as soon as you change the amplitude of one 

note more, or in a different direction, than that of the other. This line represents the amplitude 

transition between the two notes. If you move the Amplitude Tool to the end of the first note, it 

changes into the Amplitude Transitions Tool. Dragging vertically with this tool governs the speed of 

the amplitude transition, which is indicated by the steepness of the connecting line.

Amplitude transitions only exist in the case of connected notes between which there is a soft note 

separation. If you double-click on the separation with the Separation Type Tool (which you will find 

beneath the Note Separation Tool in the toolbar), you turn the soft note separation into a hard one, 

thereby disconnecting the two notes and deactivating the amplitude transition.

Muting notes

Double-clicking with the Amplitude Tool on one or more selected notes mutes them. Only the outline 

of the blobs is now shown, to indicate that the notes in question have been muted, but you can still 

select and edit them. A further double-click unmutes the muted notes.

In the Note Inspector, you will find a button marked Note Off for this function. Click once on the button 

to mute the selected notes. Clicking them a second time unmutes them.
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The reset commands

In the Edit > Reset Individual Edits > Amplitude cascading menu, you will find two commands that can 

be used to reverse the effects of the two types of amplitude editing we have just described (thereby 

restoring the notes selected in certain respects to their original state) as well as the Unmute 

command, which is self-explanatory. These commands relate always to the current selection and are 

grayed out if no editing of the type in question has been applied to the selected notes. Note that these 

commands operate independently of the normal undo function.
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Timing Tool

The Timing Tool allows you to edit the horizontal position and length of notes with or without 

quantization.

Modifying the position and length of notes

Select the Time Tool from either the toolbox or the context menu of the Note Editor or by pressing the 

[F5] key of your computer keyboard. Press the [F5] key twice or three times in quick succession to 

select, respectively, the first or second sub-tools of the Time Tool. (If you wish to assign a different 

shortcut to this tool, you may do so after choosing Melodyne > Preferences > Shortcuts > Editing 

Tools from the main menu.) There, if you wish, you can also define separate keyboard shortcuts for 

all three tools.

Click the center of a note (or of one of a number of selected notes) and drag it to the left or right to 

move the entire note (or notes) horizontally. Press and hold the [Alt] key during the movement if you 

wish the time grid to be temporarily ignored to permit finer adjustment.

If you only wish to move the beginning of a note but not the end, click on the front part of the note and 

drag. Depending on the direction of movement, the note will be time-stretched or -compressed. Press 

and hold the [Alt] key if you wish the Time Grid to be ignored when editing. Stretching and squeezing 

also acts upon either a single note or a multiple selection of notes according to choice.
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In the same way, you can move only the rightmost part of the blob (which corresponds to the end of 

the note) or selection of blobs to stretch or squeeze the corresponding note or notes.

Timing changes in the case of connected notes

Notice that as you move the beginning or end of a note in this way, the preceding or following note, if 

adjacent, is either stretched or compressed by the same amount to avoid either the two notes 

overlapping or white space (silence) appearing between them. This is invariably the case when one 

note follows directly on from another and there is a soft note separation between them. By moving the 

adjacent note as well in this way, Melodyne prevents discontinuities occurring and preserves the 

musicality of the phrasing.

You can, if you wish, deactivate the connection between consecutive notes by transforming the soft 

note separation between them into a hard separation. This is done by clicking on it with the 

Separation Type Tool (which is a sub-tool of the Note Separation Tool).

All connection between the two notes will also be forcibly severed if you cut one of the notes and 

paste it into a different location.

In both cases, when the note separation line between the two notes is replaced by a square bracket, 

it means that the notes are no longer connected.

If you move one of the two notes far enough from the other using the Timing Tool, the link between 

them will also “snap”. In this case, however, if you move it back, the original link will be restored – 

provided the position of the other note has not been moved in the meantime and that you have not 

changed tools.
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Correcting timing with a double-click

If you double-click a note with the Timing Tool, it (and any other notes selected) will snap to the 

selected grid – for example, to one of the subdivisions on the second ruler or one of the vertical lines 

indicating the start of an eighth-note. As a result, the musical beginning of the note will come to rest 

directly on top of the nearest grid line.

The musical starting point of a note is indicated by a vertical dash with an anchor at the top, and is 

found somewhere near the start of the blob but not necessarily at its leftmost extreme (which we call 

the ‘physical beginning’ of the note). Melodyne defines the musical starting point of the note to be the 

point at which the sound has unfolded sufficiently for the pitch to become discernible, as it is this 

moment that is of relevance for the purpose of quantization. Not every note, however, has a musical 

starting point. If none is present, the physical beginning of the note is used as the basis of 

quantization. (The musical starting point of notes can be edited in Note Assignment Mode).

For a note to snap to the nearest grid line, however, there must be sufficient room; if an adjacent note 

that is connected to the edited note is in the way and cannot be squeezed enough to create the 

requisite space, quantization of the note to the desired grid will be impossible. In such cases, notes 

are quantized to the nearest possible value, such as the eighth-note (quaver) nearest the desired 

quarter-note (crotchet).

If no grid is active, a note will be quantized to its ‘intended’ beat – i.e. to that indicated by the left side 

of the grey frame enclosing it. This is the beat upon which, according to Melodyne’s analysis, it was 

intended to fall.

Note: it is not possible to quantize to entire bars: only to fractions of bars.
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Adding random deviations

With the commands in the Edit > Add Random Deviations sub-menu, you can randomly alter the 

timing of the notes currently selected – introducing either slight, moderate or drastic deviations from 

the original timing. You can also employ the commands several times in succession to intensify the 

effect. These commands are useful when, for example, you’ve doubled a track in order to obtain a 

fuller or ‘fatter’ sound. By introducing random deviations, so that the copy is no longer identical to the 

original, you can simulate more realistically the effect of two performers playing or singing in unison. 

All these commands affect only the selected notes and are therefore grayed out if no notes are 

selected.

The reset commands

In the Edit > Reset Individual Edits > Time sub-menu, you will find a number of commands that can 

be used to reverse the effects of whatever editing has been performed on the timing. These 

commands apply always to the current selection and are grayed out if no editing of the type in 

question has been performed on the notes selected. Note that these reset commands work quite 

independently of the normal Undo command.
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Time Handles and Attack Speed

The Time Handle Tool and the Attack Speed Tool are found below the Timing Tool in the toolbar. 

Their purpose is to allow you to adjust the internal time path and envelope of notes.

How time handles and the Attack Speed Tool work

Time handles are handles you can affix to particular stages in the evolution of a note and drag 

sideways in order to advance or retard their attainment. In this way, you can accelerate or slow down 

particular phases of a note’s development in order to fine-tune the musical phrasing.

The Attack Speed Tool also affects the speed at which a note evolves: either by stretching and 

slowing down its early development phase and thereby accelerating its later development, or vice 

versa.

The result is either a slower, softer attack or a faster, harder one. The ‘perceived’ musical starting 

point of the note, however, remains unchanged.

Modifying the evolution of notes using time handles

The Time Handle Tool is the first of the two sub-tools of the Time Tool. To select it, press the [F5] key 

twice in quick succession. (If you wish to assign a different shortcut to this tool, you may do so after 

choosing Melodyne > Preferences > Shortcuts > Editing Tools from the main menu.) There, if you 

wish, you can also define separate keyboard shortcuts for all three time tools.

Zoom in on the note you wish to edit, so that you can see it clearly and position the time handles 

more precisely. Now double-click the point in the note’s evolution that you wish to advance or retard. 

A time handle will appear that you can move forwards or backwards in time by dragging the tool 

respectively upwards or downwards. Since the overall length of the note remains unchanged, the 

result is to shorten and accelerate the phase of the note’s development lying to one side of the time 

handle while lengthening and slowing down the phase the other side.

http://helpcenter.celemony.com/hc-2/?lang=en&startPageEdition=melodyne-assistant
http://www.celemony.com


Melodyne 4 assistant - Stand-alone

   © Celemony Software GmbH 2020 • Last updated on 12/07/2020 • Help Center • www.celemony.com 94

You can attach multiple time handles to a single note, moving each one individually, thereby 

influencing fine details of the note’s evolution. There is no limit to the number of time handles that can 

be attached to a single note. Melodyne does, however, impose constraints as to how close to one 

another the handles can be placed. If ever you find you cannot place a time handle exactly where you 

want it, try a little further along.

If you select multiple time handles using the usual selection techniques, you can move them all en 

bloc.

Double-clicking on a time handle or a selection of time handles removes them, thereby causing the 

affected phases of the note to evolve at their original speeds.

By choosing Edit > Reset Individual Edits > Time > Remove Time Handles from the main menu, you 

can remove the time handles from all the selected notes.

Changing the attack speed of notes

The Attack Speed Tool is the second sub-tool of the Time Tool. To select it, press the [F5] key three 

times in quick succession. From the Preferences dialog, you can also, if you wish, define a separate 

keyboard shortcut for this tool.

Please note that this tool has no function when the Universal algorithm is selected. You will notice 

therefore that the corresponding blobs lack handles and that the Attack Speed field in the Note 

Inspector for these blobs is grayed out.

http://helpcenter.celemony.com/hc-2/?lang=en&startPageEdition=melodyne-assistant
http://www.celemony.com


Melodyne 4 assistant - Stand-alone

   © Celemony Software GmbH 2020 • Last updated on 12/07/2020 • Help Center • www.celemony.com 95

When you select the Attack Speed Tool, a white dot appears at the start of every note. If you now 

place the tool anywhere on a note (not necessarily on the dot) and drag vertically, the dot will move 

up or down.

If you move it upwards, the attack phase of the note will be compressed and play back faster, but the 

rest of the note correspondingly more slowly. The note will therefore have a harder attack; its peak 

amplitude will be reached more swiftly.

If you move the point downwards, the opposite will occur. The beginning of the note will be stretched 

– even beyond its visible starting point – and will play back more slowly, the rest, however, 

increasingly rapidly. The attack will therefore be softer. Note that the position of the musical start of 

the note indicated by the orange anchor is not affected by changes in attack speed. The ‘perceived’ 

start of the note is therefore independent of the attack speed. The end of the note is in all cases 

unaffected.

You can vary the attack speed of notes individually, in order to accentuate them. You can also, 

however, select and modify the attack speeds of multiple notes simultaneously and thereby alter the 

timbre of an entire phrase.

If you double-click on a note or one of a selection of notes with the Attack Speed Tool, the 

corresponding parameter will return to its neutral (central) position. The same result can be achieved 

by choosing Edit > Reset Individual Edits > Time > Reset Attack Speed from the main menu.
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Combining time handles with the Attack Speed Tool

You can combine the use of time handles with that of the Attack Speed Tool. Altering the attack 

speed in this case will cause the time handles to move, functioning as a kind of timing master. You 

can therefore shape the evolution of the note to enhance the phrasing before adjusting the overall 

timing (so that the note starts faster or more slowly) with the Attack Speed Tool.

http://helpcenter.celemony.com/hc-2/?lang=en&startPageEdition=melodyne-assistant
http://www.celemony.com


Melodyne 4 assistant - Stand-alone

   © Celemony Software GmbH 2020 • Last updated on 12/07/2020 • Help Center • www.celemony.com 97

Note separation tools

With the Note Separation Tool, you can cut notes as well as removing and moving note separations. 

With the Separation Type Tool, you can switch between hard and soft separations.

Inserting, moving and removing note separations

Select the Note Separation Tool from either the toolbox or the context menu of the Note Editor or by 

pressing the [F6] key of your computer keyboard. (If you wish to assign a different shortcut to this 

tool, you may do so after choosing Melodyne > Preferences > Shortcuts > Editing Tools from the 

main menu.)

By double-clicking within a note with the Note Separation Tool, you can introduce a note separation 

and thereby slice the note in two.

Don’t be surprised if the resulting pair of notes move apart in pitch; this is because as soon as the 

fission occurs a new tonal center is calculated for each of the newly created notes, and their 

respective tonal centers may differ from the tonal center the notes shared when they were one. In 

such cases, each therefore moves to a new vertical position based on its newly calculated pitch 

center.

You can move an existing note separation horizontally simply by dragging it with the Note Separation 

Tool.

You can double-click a note separation to remove it.

Editing note separations with multiple notes selected

If you select several notes and move a note separation, the note separations of the other selected 

notes will also be moved. If you double-click one of the note separations to remove it, the note 

separations of the other selected notes will also be removed.
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If you have selected several notes that overlap, you can insert a note separation in the same place in 

all of them simultaneously as well as move or remove one.

Soft and hard note separations

Depending upon the audio material and the algorithm selected, Melodyne places either soft or hard 

separations between notes. Soft separations only occur between consecutive notes and provide a 

link between the notes: if the end of the first note is moved, the beginning of the second note moves 

along with it, to ensure that no gap opens between them. This helps you preserve phrasing when 

editing.

The connection between notes also plays a role in the pitch, formant and amplitude transitions 

between notes: such transitions are only possible in the case of connected notes between which a 

soft separation exists.

In the case of a hard separation, consecutive notes are independent of one another. This means that 

changing the length of the first note has no affect upon the position of the second. It also means there 

are no pitch, formant or amplitude transitions between the two notes.

Soft separations are indicated by a thin vertical line between notes, whereas hard separations are 

denoted by a bracket.

Switching between hard and soft separations with the Separation Type Tool

The Separation Type Tool is the sub-tool of the Note Separation Tool. It allows you to toggle between 

hard and soft separations. To select it, press the [F6] key (assigned by default to the note separation 

tools) twice in quick succession. If you would prefer to use some other key combination, choose 

Preferences -> Shortcuts -> Editing Tools -> Note Separation Tools and press the keys of your 

choice. If you wish, you can define separate keyboard shortcuts for each of the two tools.

Double-click on a separation with this tool in order to change its type.
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Please note that it is only with certain separations that the option of switching freely between ‘soft’ 

and ‘hard’ exists.

Soft separations can always be turned into hard ones.

Hard separations, however, can only be turned into soft ones if they were soft to begin with 

and their type has subsequently been changed. An exception to this rule is material detected 

using the Percussive algorithm; in this case, all separations are initially hard but can be turned 

into soft ones.

Separate Notes as Trills

When the Note Separation Tool is selected, you will find the command “Separate Notes as Trills” in 

the Note Editor’s context menu. The effect of this is to slice a selection of one or more notes into 

smaller segments determined by the instantaneous pitch of each note. This is done by inserting note 

separations into the slopes of the pitch curve as it rises and falls, thereby turning each ‘hill’ and each 

‘valley’ of a vibrato into a separate note.

The use of this command allows you, for example, to improve the intonation of a trill, by tuning the 

notes more closely to their intended pitches, or to rein in an unruly vibrato, by applying the Correct 

Pitch Macro to its upper and lower extents.

Please note that the fluctuations in the Pitch Curve must be fairly pronounced for the “Separate Notes 

as Trills” function to have any effect and that it is only available when the Melodic algorithm is active, 

being grayed out in every other case. If you wish to assign a shortcut to the command “Separate 

Notes as Trills”, this can be done using the Preferences dialog.

Separate Note

This command separates notes automatically at a point determined by Melodyne. It is useful when 

you need to make precise cuts in a vocal passage and isolate sibilants or breathing noise prior to 

editing using the tools.

You will find the “Separate Note” command in the context menu of the Note Separation Tool and on 

the “Shortcuts” page of the Preferences property sheet, where you can assign a keyboard shortcut to 

it.
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The Note Inspector

The Note Inspector in the info pane offers you an overview of the parameters of the selected note(s) 

and allows you to alter the values.

The parameters of the Note Inspector

The Note Inspector brings together the inspector fields that are usually displayed near the toolbar 

when the various tools are in use. It allows you to see all the most important parameters at a glance 

and even edit them without having to change tools.

In addition to the data included in the inspector fields, the Note Inspector displays the frequency in 

hertz as well as a button for the muting of notes.

The editable parameters displayed in the Note Inspector are (from top to bottom):

the pitch of the selected note in semitones, cents and hertz

the pitch modulation expressed as a percentage

the pitch drift expressed as a percentage

the formant shift in cents

the amplitude in decibels

the button for muting and unmuting notes

the attack speed expressed as a percentage
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Lower down in the inspector, you can see to which audio file the selected note belongs and which 

algorithm was used for the detection.

Entering values and handling multiple selected notes

When only one note is selected in the Note Editor, the Note Inspector displays the concrete values for 

that note.

As a general rule, you can modify all values either by clicking in their respective fields and dragging 

the mouse pointer upwards or downwards or by double-clicking in the field and typing in a new value.

In the case of the Pitch field, you can enter either an absolute (C3, D4 etc.) or a relative (+2, -1, etc.) 

value. In the other fields, it is always the absolute value that is adopted.

If you have selected multiple notes, the Note Inspector will only displays concrete values for 

parameters if these are shared by all the selected notes. Where values differ, a dash “–” is displayed 

in the relevant field.

If a dash is displayed, by clicking on it and dragging, you can alter the individual values of all the 

notes selected by the same amount; in this way, for example, you could transpose an entire selection 

up two semitones. The Scale Snap function, of course, if activated, will govern the eventual 

destination of the various notes.

As you drag the values, Melodyne remembers the difference between them. This is even true when 

certain parameters ‘collide’ with their maximum or minimum values; provided you keep the mouse 

button pressed and drag then in the opposite direction, the initial difference will be restored. Only if 

you release the mouse button at the point of collision will the initial difference be forgotten.

Alternatively, with multiple notes selected, you can type in a value that will then be assigned to, and 

thereafter shared by, all the selected notes (whereupon the dash, of course, will disappear).

An exception here is the pitch, as, if you type in the value “2”, for example, all the selected notes are 

shifted two semitones upwards. If you wish to assign the same pitch to all the selected notes, type in 

an absolute value, such as “C2”. If the Percussive or Universal algorithms are selected, of course, this 

has no effect, as these algorithms only know relative pitch.
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Copying notes

To copy notes in Melodyne, first select the desired notes, then choose Copy from the Edit menu or 

the context menu of the Note Editor. To insert them, use the Paste command. The following points 

here need to be noted.

The selection, cursor and grid when copying

When you copy notes to the clipboard using the Copy command, you will notice that the cursor 

moves to the start of the selection, or, to be more precise, to the quarter-note (crotchet) on the Time 

Grid closest to the first note of the selection.

If, with the notes still selected, you use the Paste command, all that appears to happen is that the 

notes that were selected prior to the paste are now no longer selected and the cursor is now located 

just after the last of them.

In fact, however, the notes previously selected have been replaced by those on the clipboard. In other 

words, the notes have been copied onto themselves, with the copies replacing the originals. 

Admittedly, this may not sound particularly useful, but look at the position of the cursor: it is now 

aligned with the quarter-note on the Time Grid closest to the last copied note.

If you now execute a further Paste, the notes on the clipboard will be pasted a second time. This time, 

however, since no notes were selected, nothing will be replaced. Instead, the newly pasted notes will 

end up just after those that replaced the originals the first time round.

Their position is now determined by the cursor. And since, after the first paste, this was aligned with a 

quarter-note on the Time Grid (the first quarter-note after the pasted notes, to be specific), the effect 

of the second paste is that the original alignment of the notes relative to the gridlines is reproduced 

exactly, only further along the timeline. This behavior allows you to string together a succession of 

copies of the same passage, quickly and accurately – in order, for example, to create multiple 

iterations of a drum loop.
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Based on what we have just seen, we can formulate the following rules:

If any notes are selected when the Paste command is executed, these are replaced by the 

contents of the clipboard. The pasted notes are stretched or squeezed until they fit exactly the 

range from the beginning of the first to the end of the last note of the selection. This is 

illustrated here: on the left are the notes to be copied; in the centre, a single selected note, 

which serves as the destination of the copy; on the right is the result after the paste is 

performed: The selected destination note has been replaced and the pasted notes squeezed 

just enough for them to fit exactly the space it occupied.

If when the Paste is executed no notes are selected, the cursor determines the point at which 

the pasted passage begins. The grid settings here play an important role: when copying notes 

to the clipboard, Melodyne remembers the distance between the first of the copied notes and 

the nearest grid line. When the paste is repeated at the new cursor position, the offset of the 

first pasted note to the gridline nearest to  will be exactly the same.it

In other words, notes in Melodyne are not copied in such a way that they necessarily coincide with 

gridlines, because then the subtleties of expression would be lost. Instead, the notes copied retain 
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their respective offsets to the grid. There is an exception, however, to this rule: if, instead of being 

calibrated in beats, the grid is calibrated in seconds (i.e. if you have selected “Sec” from the Time 

Grid Settings drop-down menu to the right of the Time Ruler), then the note (or first of a series of 

copied notes) will begin exactly at the cursor position, with no offset.

After each paste, the cursor is moved to the first quarter-note following the most recent paste, 

making it easy to string together multiple iterations of the same passage. Obviously, if you 

wish, you can move the cursor by hand to some other point on the Time Ruler and make that, 

rather than the automatically selected quarter-note, the reference point for the next paste. You 

might want to do this, for instance, to introduce a pause between iterations.

The pitch of the copied notes is always the same as that of the originals. This is even true 

when notes are selected, and therefore replaced, when the paste is performed. The length of 

the passage selected, in this case, is retained but the original pitch of the notes it contained is 

not. Of course, after performing the paste you can move the notes by hand to any pitches you 

like.

Tempo adjustment when copying: the Auto Stretch Switch

If notes are selected when the paste is performed, the inserted passage will be stretched or squeezed 

to fill the available space (i.e. that between the beginning of the first selected note and the end of the 

last) as we have already seen. But how is the tempo of the copied passage treated when the position 

of the paste is determined instead by the cursor?

If the tempo at the destination of the paste is different from that of the passage from which the notes 

were copied, it is the status of the Auto Stretch Switch that determines whether the pasted notes 

adjust to the tempo of the destination or retain their original tempo. If the Auto Stretch Switch is on, 

they adjust; if it is off, they do not. So unless you want to change the tempo at the cursor position, you 

should switch Auto Stretch on before performing the paste.
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The Edit menu

Melodyne’s Edit menu includes items that allow you to reset individual edits and add random 

deviations to the audio material.

Resetting edits

The Reset Individual Edits sub-menu contains commands that nullify the effects of various types of 

editing.

You will also find in the context menu of the Note Editor whichever of these commands are relevant to 

the tool you are using at the time.

The commands invariably apply to the current selection and are grayed out if no editing of the type in 

question has yet been applied to the selected notes. Notice that these reset commands work 

independently of the normal undo function.

The effect of the following types of editing can be reversed via the Reset Individual Edits sub-menu:

Pitch

all changes of pitch

editing of the pitch center

editing of pitch modulation

editing of pitch drift

editing of pitch transitions

Formants

editing of formants

editing of formant transitions

Amplitude

editing of amplitude
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editing of amplitude transitions

the muting of notes

Time

all editing of timing (start position / length of notes)

the placing of time handles

editing of the attack speed

The final command, Restore File to Original State, reverses in one go the effects of all editing 

(regardless of type) that has been performed on the audio file.

Adding random deviations

The Add Random Deviations sub-menu varies the pitch or timing of individual notes a) drastically, b) 

by a moderate amount, or c) in a subtle way; within these various limits, the direction and extent of 

the deviation is determined randomly.

The commands introduce random variation to either the pitch or the timing of the selected notes, and 

their effect, if the command is used several times in succession, is cumulative.

Random deviations are particularly useful when you have made one or more copies of a single take 

but do not wish them to be identical either to each other or to the original – the object being, perhaps, 

to make a single vocalist sound like a choir. Through the addition of a certain amount of random 

deviation to each copy you can obtain more natural-sounding results by ensuring that the 

synchronization of the individual voices is never improbably perfect and that no two copies exhibit 

identical fluctuations in pitch.
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Audio to MIDI

From this tour, you will learn how to save audio notes in Melodyne as MIDI notes.

About Audio-to-MIDI

Melodyne allows you to export audio notes as MIDI notes. When this is done, a file in Standard MIDI 

file format is created and saved to your hard disk. This file can then be loaded into your DAW, so you 

can use it, for instance, to double your vocals with a sound from a software synthesizer.

The MIDI notes are an exact representation of the audio notes in Melodyne. For each audio note, a 

MIDI note is created with the same position, length and pitch. The velocity of each MIDI note is 

derived from the amplitude of the audio note it represents.

When you save rhythmic material as MIDI, all the MIDI notes will share the same pitch but take their 

position, length and amplitude from their audio equivalents in the rhythm track. You can use this 

technique, for example, to derive from a drum loop a quantization reference for other MIDI tracks in 

your DAW.

The generation of MIDI notes from audio material offers a wealth of different creative possibilities. Try 

it out for yourself!

Saving MIDI from the stand-alone implementation of Melodyne

To save audio material from the stand-alone implementation of Melodyne as a MIDI file on your hard 

disk, choose File > Export... Mute beforehand the tracks you do not wish to export.

In the Export window, you will find various options. First using the pop-up button on the left select 

MIDI in the first line; this will gray out the irrelevant options for exporting audio.

In the second line, select the Range (i.e. the portion of the timeline) you wish to export.

Entire Length: Everything from the beginning to the end of your project.

Cycle Range Only: Only the segment between the cycle locators.
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The “Include tails” option should be selected when you wish to limit the length of the exported 

material to the cycle range but certain of its notes have not finished sounding when the end of the 

range is reached. If you choose “Include tails”, the exported segment will be extended just enough to 

prevent the tails being chopped off.

Click on Export to begin the MIDI export with the selected options. A file selector will open so that you 

can choose the storage location.
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Tempo detection and Auto Stretch

Melodyne is capable of recognizing not only the notes but also the prevailing tempos and time 

signatures within a recording.

Introduction

Melodyne’s tempo detection and tempo adjustment functions are used often and to great effect, yet 

they execute for the most part quietly in the background. Example: Drag a recording, a phrase or a 

loop into a document in the stand-alone implementation of Melodyne. Melodyne detects the tempo of 

the music and adjusts it to that of your project (even if this includes gradual tempo changes). The 

audio file runs in sync without your having to give it a moment’s thought.

No tempo detection is performed in two cases:

When an assignment file containing the results of a previous detection and any editing thereof 

has already been saved for the new audio file – here the tempo has been detected already so 

there is no need to repeat the process;

When Apple loops are imported, as these already contain information regarding their tempo – 

here, again, further analysis of the tempo would be pointless.

People often record to a click so that a timing reference will be available later. Often this metronomic 

click is felt to be constraining: Without the click, there is greater freedom and the music that results 

sounds more dynamic and vibrant; it is capable of ‘breathing’.

With Melodyne, you can dispense with the use of a click when recording and still retain a timing 

reference. The trick is simple: Instead of playing to the click resulting in a rigid timeline, with Melodyne 

you can simply adopt the tempo map of the actual recording – with all the minor fluctuations in tempo, 

sudden or gradual tempo changes, and changes in time signature it contains. The music, in other 

words, dictates to the timeline – not the other way around.

Tempo in the stand-alone and plug-in implementations

Melodyne’s tempo detection only plays a role in the stand-alone implementation of the program; not 

in the plug-in. The reason is simple: The plug-in operates within a DAW from which it adopts not only 

the audio material but also all tempo information.

Determining the tempo in the stand-alone implementation

In the stand-alone implementation of Melodyne, with a new document the tempo and time signature 

fields are initially empty; instead of a value in each case a simple dash (“–”) is displayed.
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The Time Ruler, initially, is calibrated in seconds. So you begin with a blank sheet and can either 

enter the tempo and time signature for the Melodyne project manually or allow Melodyne’s tempo 

detection routines to do their work.

To enter the tempo manually, proceed as follows (the default values, unless others are entered by 

hand, are 120 BPM for the tempo, 4/4 for the time signature, and quarter note (crotchet) intervals for 

the Time Grid):

Enter the desired value in beats per minute (BPM) in the tempo field

Enter the desired values for the numerator and denominator of the time signature

Enter a musical note value instead of seconds in the menu for the Time Grid

Click on the button between the time signature and tempo fields in the transport bar to activate 

the metronome. If you are used to working with a DAW, you may prefer to set the tempo 

manually before beginning work on your project. Since Melodyne is extremely good at 

detecting the tempo, it is in many cases easier and more practical simply to allow Melodyne’s 

tempo detection routines to determine the tempo for you.

To allow Melodyne’s tempo detection routines to determine the tempo, proceed as follows:

Instead of initializing the tempo, time signature and Time Grid values manually, as just 

described, begin recording with the tempo and time signature fields empty. Now you no longer 

need a click to listen to as you record because Melodyne will detect the tempo and tempo 

fluctuations within the recording and adjust the grid lines and subsequent click accordingly. 

Instead of entering a numerical value for the tempo, in other words, you are determining the 

tempo through your performance.

Melodyne’s tempo detection routines work in an analogous fashion when, instead of recording, 

you import previously recorded audio. The same condition applies here: you must begin with a 

blank sheet i.e. you must leave the tempo and time signature fields and the Time Grid menu 

untouched. To determine the tempo by means of an audio file, you must load it either by 

choosing File > Import Audio from the main menu or by drag ‘n’ drop. Melodyne will then 

detect the tempo of the file, set the project tempo accordingly and position the file in such a 

way that its musical content begins at Bar 1. As a rule, the first note of the music appears in 

Bar 1, with any silence in the recording that precedes the first note falling in the negative zone 

of the Time Ruler. If the music begins with an anacrusis, however, (i.e. one or more 

unstressed notes that precede the first bar line), Melodyne places this in Bar -1, so that the 

stress falls on the downbeat at the start of Bar 1.
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Auto Stretch when importing additional audio files

Once the tempo has been determined, by whichever means, your project will have a tempo map with 

a time signature, an appropriately spaced grid and a tempo curve tracing any fluctuations in tempo it 

contains. The presence of this tempo map introduces new possibilities when additional files are 

imported; possibilities that were not present when we were working with a blank sheet. The Auto 

Stretch Switch, for example, which was grayed out before, now offers you two choices:

With Auto Stretch switched on, every new file imported into the project will be adjusted to 

ensure it conforms to the tempo map in place and replicates any tempo changes it contains. 

To make this possible, Melodyne first analyzes the tempo of the material to be imported and 

then squeezes or stretches it wherever necessary to match the tempo of the project.

With Auto Stretch switched off, no attempt is made to adjust the tempo of the imported file to 

that of the project; so initially, it simply plays back at its original speed. You are perfectly free, 

of course, once the material has been imported, to stretch or squeeze notes to your heart’s 

content as you edit the material. All turning off the Auto Stretch switch does is prevent the 

tempo of the imported file adjusting  to the tempo map of the project.automatically

Where on the Time Grid the file is initially positioned depends upon the procedure used to import it:

If you choose File > Import Audio from the main menu , the physical start of the file (i.e. the 

first sample) will be aligned with the “0:00” seconds mark on the Time Ruler, which may be, 

but is not necessarily, the beginning of Bar 1. If the Auto Stretch Switch is on, the file will 

adjust to the project tempo; otherwise not.

If you import the file by dragging it to a particular point on the Time Ruler (the “dropping point”) 

and Auto Stretch is switched on, the file will be aligned such that the first beat of the first 

complete bar coincides with the dropping point; if Auto Stretch Switch is off, the physical start 

of the file will be aligned with the dropping point. When this procedure is used, the file will snap 

to whichever line on the Time Grid is closest to the dropping point, so your Time Grid setting 

(quarter notes, eighth notes, sixteenth notes…) is of importance here – unless, of course, you 

wish the grid to be disregarded, in which case hold down the [Alt] key as you drag and drop 

the file onto the Time Ruler.

If, instead of a time value, the Time Ruler is calibrated in seconds, the Auto Stretch function is 

automatically disabled; the Auto Stretch Switch is grayed out and no attempt is made to adjust the 

tempo of the imported file to that of the project.
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Auto Stretch when notes are moved or copied

The Auto Stretch Switch plays a role not only when audio is imported but also when notes are moved 

or copied.

If at the destination (i.e. the point to which the notes are moved or pasted) the tempo differs from that 

of the source (i.e. the place from which they are taken), depending upon whether Auto Stretch is 

switched on or off they either adopt the tempo of the destination or retain that of the source. As a 

general rule, before copying or moving notes you will want to switch Auto Stretch on, so that they 

adjust to the tempo of the destination.
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Version history

Here you will find an overview of all changes introduced by the most recent Melodyne updates.

New in Melodyne 4.2.3

Fixed: In Version 4.2.2, Melodyne in certain configurations displayed the message “expired” at 

start-up and refused to launch.

New in Melodyne 4.2.2

New functions and improvements

Better window management in Studio One 4: Melodyne’s zoom and other window settings now 

remain constant when you select a new audio region, instead of being displayed with individual 

settings as previously.

Bug fixes

Fixed: In Cakewalk, under certain circumstances, instead of new files being analysed 

automatically, you had to select an algorithm manually in order to trigger the detection process.

Fixed: In the stand-alone implementation of Melodyne, closing a project without saving 

sometimes led to a crash if other projects were open at the time.

Fixed: In Logic, validating the Melodyne plug-in sometimes slowed down the launch of the 

DAW.

Fixed: In the stand-alone implementation of Melodyne, opening or importing projects under 

certain circumstances led to a crash.

Fixed: In ARA mode, it could happen under certain circumstances that the monitoring during 

blob editing no longer functioned after starting and stopping playback.

Fixed: In Cakewalk, selecting a new clip sometimes led to a misalignment of the Melodyne 

position display.

New in Melodyne 4.2.1

New functions and improvements

Faster loading with ARA: In DAWs with ARA support, extensive projects now load considerably 

faster.

Bug fixes
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Fixed: During ARA operation with Mixcraft and Cakewalk, blob monitoring and scrubbing were 

no longer available in Melodyne if you started playback in the DAW.

Fixed: With Melodyne in Player Mode (i.e. without activating the program on the computer 

being used), the ARA plug-in sometimes crashed when you switched from Track Edit Mode to 

Clip Edit Mode.

Fixed: If the detection was aborted after a transfer with the Melodyne plug-in and you 

subsequently tried to move audio material whilst holding down the ALT key, a crash was 

sometimes the result.

Fixed: If an audio file was selected in the track pane of the stand-alone implementation of 

Melodyne studio, adjusting the fine tuning in the inspector sometimes led to a crash.

New in Melodyne 4.2

Thanks to ARA, now more fully integrated: Melodyne and Logic

Thanks to ARA Audio Random Access, Melodyne 4.2 and Logic Pro X 10.4.3 work more closely and 

efficiently together. Here are the most important workflow advantages in a nutshell.

You can open tracks without transfers: Just load Melodyne as an insert effect, start playback and 

the entire track will appear automatically in Melodyne. There is no further need for transfers.

Melodyne follows all changes you make to the track: Melodyne compares its contents to those of 

the audio track and accurately replicates any lengthening, shortening or movement of regions.

Real copies and ghost copies of regions: When regions are copied, looped or cloned, the 

Melodyne content behaves accordingly as a real copy or as a ghost copy (Loop).

Region-based mixing: Regions edited with Melodyne now support all the mix functions of the region 

inspector in Logic: Region, Gain, Mute and Fades.

You can use Melodyne as early as the comping stage: Now you can edit takes with Melodyne 

before committing yourself to a choice between them, which gives you a more realistic assessment of 

their respective merits, leading to better results.

The management of transfer files is a thing of the past: Thanks to ARA, there is no need anymore 

to keep transfer files in mind and archive them or pass them on to collaborators.

More...

New functions and improvements

ARA in Logic: Melodyne 4.2 supports ARA integration into Apple’s new Logic Pro X 10.4.3. With 

ARA, transfers are no longer necessary in Logic, and Melodyne follows all changes made to the 

audio track.
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The transfer path in Cakewalk/Sonar: When using the Melodyne VST3 plug-in in Cakewalk/Sonar, 

the transfer path is now created automatically within the current project (Cakewalk Projects / <project 

folder> / Melodyne / Transfers).

Improved interaction: Melodyne 4.2 interacts even better with Studio One and now requires Studio 

One Version 3.5.6 or later.

Additional keyboard shortcut: You can now assign a keyboard shortcut from the Preferences 

dialog for the command “Reseparate Notes at Starting-Point Lines” that appears in the context menu 

in Note Assignment Mode; the shortcut is then also available in edit mode.

Bug fixes

Fixed: In Studio One, in projects with many Melodyne clips, the generation of additional 

Melodyne instances (using the command “Open in Melodyne”) sometimes slowed down the 

program.

Fixed: In Studio One under Windows, the color of the note background used to change when 

you altered the zoom level.

Fixed: In Studio One, the function “Unison Spread” sometimes shifted the notes in Melodyne 

several octaves.

Fixed: In Studio One, use of the Note Separation Tool under certain circumstances led to a 

crash.

Fixed: In Studio One, the note display (the lines superimposed on the waveform) was 

previously not updated when notes were deleted in Melodyne.

Fixed: In Studio One, in the case of copied events, “Follow Clip Selection in the DAW” resulted 

in the wrong bars being shown.

Fixed: In Cakewalk/Sonar, the export of a 16-bit audio file edited with Melodyne sometimes led 

to a crash.

Fixed: In Cakewalk/Sonar, use of the Freeze function sometimes led to a crash.

Fixed: In all DAWs with ARA, changes to the key or scale were previously not saved.

Fixed: In all DAWs with ARA, use of the Compare switch stopped local playback in Melodyne.

Fixed: In Logic 10.3, the opening of some projects with Melodyne could lead to a crash.

Fixed: In Digital Performer, the opening of projects previously edited with Melodyne sometimes 

led to a crash.

Fixed: In the plug-in, the command “Restore File to Original State” could under certain 

circumstances result in the wrong notes being deleted.

Fixed: Canceling a transfer could lead to a display error or even (if you proceeded with editing 

) to the DAW crashing.

Fixed: In the plug-in, the assignable keyboard shortcut “Repeat Last Menu Action” did not work.

Fixed: If the Scale Window was open when you switched from edit mode to Note Assignment 

Mode, the wrong area of the timeline used to be displayed.

Fixed: In the Sound Editor, no peak values were displayed for the spectrum when Note 

Assignment Mode was active.
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Fixed: In Melodyne studio’s track list, the “Edit” and “Reference” buttons could both be 

activated by Alt-clicking.

Fixed: In Melodyne studio, when multiple tracks were copied simultaneously, their contents 

were sometimes swapped.

Fixed: In Melodyne essential, the assignable keyboard shortcut for “Separate Notes as Trills” 

was missing.

Fixed: In Melodyne essential, opening a document saved by Melodyne studio sometimes 

resulted in the wrong track being displayed.

Fixed: In the stand-alone application, it was impossible to copy and paste notes in Tempo 

Assignment Mode.

Fixed: In the stand-alone application, a new detection sometimes led to the audio being offset 

in the timeline.

Fixed: In the stand-alone application under macOS Version 10.12, crashes sometimes 

occurred when the import audio function was used.

New in Melodyne 4.1.1

New functions and improvements

The “Separate Note” command

This command separates notes automatically at a point determined by Melodyne. It is useful when 

you need to make precise cuts in a vocal passage and isolate sibilants or breathing noise prior to 

editing using the tools.

You will find the “Separate Note” command in the context menu of the Note Separation Tool and on 

the “Shortcuts” page of the Preferences property sheet, where you can assign a keyboard shortcut to 

it.

A shortcut for the command "Separate at Starting Point Lines"

From the “Shortcuts” page (heading: “Note Assignment”) of the “Preferences” property sheet, it is now 

possible to assign a keyboard shortcut to the command “Separate at Starting Point Lines” that is used 

in Note Assignment Mode; this command could previously only be accessed from the context menu 

of the Note Separation Tool.

Bug fixes

Fixed: graying out under certain circumstances of the buttons used to open the macros

Fixed: occasional crashes when the Note Separation Tool was used in Note Assignment Mode 

and the threshold value was altered

Fixed: alteration under certain circumstances of the length of an audio file when saving

Fixed: crashes occurring in rare cases when multiple recordings followed in quick succession

Fixed: crashes occurring in certain circumstances with Logic Pro 10.3.1 under macOS 10.12.x 

and 10.11.x

Fixed: crashes coincident with the opening of some projects with Logic 10.3
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Fixed: crashes occurring sometimes in Sonar when an ARA region was frozen

Fixed: occasional interruptions of the simultaneous transfer of four or more tracks with Digital 

Performer 9.13 under macOS 10.11.6

Fixed: memory leak with FL Studio

New in Melodyne 4.1

The update brings important improvements to all editions of Melodyne, including a new playback type 

for high-pitched monophonic instruments, a command for separating notes as trills and additional 

keyboard shortcuts. When Melodyne is integrated into the DAW by means of the ARA interface 

extension, user-friendly new possibilities are now available for vocal comping, and in Melodyne 4 

studio, the simultaneous editing of an unlimited number of tracks can now be done via ARA, too.

In ARA-compatible DAWs, Version 4.1 offers decisive improvements that make it possible to focus 

Melodyne’s functions in an optimal manner on an individual clip or an entire track. In Clip Mode, you 

have access to a single clip, but this extends to notes lying beyond its borders; as a result, when 

comping it is very simple to solve any problems posed by clip borders slicing notes in two, which 

greatly streamlines the comping workflow. In Track Mode, on the other hand, you see all clips of a 

track exactly as these are cut and arranged in the DAW. The two modes complement each other 

perfectly and offer ideal editing possibilities in ARA-compatible DAWs.

When Melodyne is integrated into a DAW by means of ARA, Version 4.1 now allows the simultaneous 

display and editing of an unlimited number of DAW tracks in a single Melodyne plug-in window – ideal 

for backing vocals and other multitrack applications.

The ARA Audio Random Access interface extension, which is currently supported by Presonus Studio 

One, Cakewalk Sonar, Magix Samplitude and Tracktion, makes the use of Melodyne particularly fast 

and efficient. DAW tracks can be edited directly without any time-consuming transfers; furthermore, 

Melodyne follows automatically any changes made to the tracks. The result is that Melodyne feels like 

a comfortable integrated sample editor – but one that allows the note-based editing of tracks.

New functions and improvements

Multitrack Note Editing now also during ARA integration

In Melodyne studio 4.1’s Note Editor, you can now also with ARA integration display and edit as many 

DAW tracks simultaneously as you like.

ARA improvements for (vocal) comping in the DAW

Thanks to two new ARA modes, Melodyne’s power can be optimally focused on an individual clip or 

an entire track, thereby providing ideal support for typical DAW workflows such as (vocal) comping: 

ARA Clip Mode affords access to a single clip but also to notes on either side of the clip borders. ARA 

Track Mode, on the other hand, shows you all the clips on a DAW track, exactly as they are edited 

and arranged there.
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New playback type for monophonic instruments

To enhance sound quality during the playback of soprano voices or very high-pitched melodic 

instruments (e.g. piccolos), the Algorithm Inspector now includes a new playback type: “Tonal (high)”.

The “Separate Notes as Trill” command

The Note Editor and Note Assignment Mode now feature Melodyne studio 3’s familiar “Separate 

Notes as Trill” command.

The “Separate Note” command

This command separates notes automatically at a point determined by Melodyne. It is useful when 

you need to make precise cuts in a vocal passage and isolate sibilants or breathing noise prior to 

editing using the tools.

A shortcut for the command "Separate at Starting Point Lines"

From the “Shortcuts” page (heading: “Note Assignment”) of the “Preferences” property sheet, it is now 

possible to assign a keyboard shortcut to the command “Separate at Starting Point Lines” that is used 

in Note Assignment Mode; this command could previously only be accessed from the context menu 

of the Note Separation Tool.

The “Replace Audio” command

The “Replace Audio” command allows you to save an audio file under its existing name without 

having to open the Export dialog.

Better keyboard shortcuts

Every sub-tool now has its own independent shortcut. A shortcut has also been added for the Time 

Grid, and Zoom commands assigned to the numerical keypad.

Contrast variations for the user interface

In the Preferences dialog, several new contrast options are available for the user interface.

HiDPI support under Windows

On suitable systems running Windows 8 or later, Melodyne now supports the high resolution screen. 

This applies to both the stand-alone implementation and the plug-in in Studio One. HiDPI support for 

further DAWs is planned.

Reduced memory requirements

Thanks to internal optimization, the memory requirements under Windows in particular of Melodyne 

4.1 (stand-alone, plug-ins and ARA) have been reduced.

Auto Scroll options

When running Melodyne as a plug-in, you can now save separate Auto Scroll settings for each 

instance.
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iLok

In addition to the iLok 2, Melodyne 4.1 now supports the new iLok 3.

Bug fixes

Fixed: under Windows 7, certain MP3 files when loaded causing Melodyne stand-alone to 

crash

Fixed: in Cubase, the setting “Always on Top” for the plug-in window sometimes leading to a 

crash

Fixed: various graphics problems in the plug-in

Fixed: entered or detected tonalities reset to C Major when saving

Fixed: MAR files from Melodyne studio 3 imported by Melodyne 4 with incorrect tempo 

information

Fixed: sundry other problems affecting the import of studio 3 files

Fixed: shift by a few samples of audio material after a later change of algorithm

Fixed: occasional misalignment of the Time Grid after tempo learning in the DAW

Fixed: unreliable transfer to the Melodyne plug-in of information regarding changes of time 

signature in Cubase’s Learn Tempo dialog

Fixed: crashes occurring in certain circumstances with Logic Pro 10.3.1 under macOS 10.12.x 

and 10.11.x

Fixed: crashes coincident with the opening of some projects with Logic 10.3

Fixed: occasional crashes when the Note Separation Tool was used in Note Assignment Mode 

and the threshold value was altered

Fixed: alteration under certain circumstances of the length of an audio file when saving

Fixed: crashes occurring sometimes in Sonar when an ARA region was frozen

Fixed: graying out under certain circumstances of the buttons used to open the macros
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Switching to Melodyne studio trial mode

Explore all the possibilities Melodyne has to offer! To do this, simply switch your Melodyne essential, 

assistant or editor to Melodyne studio trial mode. If you do not have Melodyne, you can download the 

.trial version here

Switching to trial mode

When you switch to trial mode, your Melodyne essential, assistant or editor will be transformed for 30 

days – free of charge and without obligation - into Melodyne studio, the largest Melodyne edition, 

which contains the full range of Melodyne functions. You can use all these functions for 30 days 

without restriction, exactly as if you had purchased Melodyne studio. Trial mode can only be activated 

once on the same computer. To switch to trial mode, and each time you launch Melodyne studio 

during the trial period, you will need an Internet connection.

Here’s how to activate trial mode:

1) Start Melodyne. Next go to the Help menu and select “License”.

In the plugin:

In the stand-alone implementation:

2) You will be directed to your user account in your browser where you will see your license options. 

In the “Melodyne studio trial mode” frame, switch to trial mode:
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That’s all there is to it. Trial mode will remain active for 30 days, so when you return now to Melodyne 

you will see that the “Melodyne studio” edition is running.

Comparing editions

If you wish, you can switch to a smaller edition in the course of the trial period in order to compare the 

range of functions offered by the various editions. This could be useful, for instance, if you own 

Melodyne essential and are wondering which of the larger editions to upgrade to. Easy. Just try them 

all.

To switch editions, select “License” from the Help menu exactly as before. This will take you back to 

your user account in your browser, where you will be given the option of switching to one of the 

smaller editions.

Your choice, however, will only remain effective while Melodyne is actually running. As soon as you 

restart Melodyne, the full Melodyne studio function set will be restored.

Expiry of the trial period

At the end of the 30-day trial period, Melodyne will automatically revert to your previous edition. 

Further editing of projects created during the trial period will still be possible, but only using the 

functions of your previous Melodyne edition. Playback, however, will be unaffected, so none of the 

work you did during the trial period will be lost.

Convinced?

If you wish, you can switch permanently to Melodyne studio at any time during the trial period or 

thereafter. The requisite upgrade can be obtained  or from your local dealer.from our web shop
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Troubleshooting

If you have problems, you will find advice here. Additional topics can be accessed by clicking on 

“FAQ” in the side menu.

If the tips do not help contact support@celemony.com. Our support staff speaks English and German.

I’m not sure how to install Melodyne correctly.

Just run the installation program that you received as a download or that you will find on your 

Melodyne CD. This will install both the stand-alone implementation of Melodyne and the various plug-

ins onto your computer.

I have installed Melodyne but cannot find it.

Under macOS, the stand-alone implementation of the program is called “Melodyne”. You will find it in 

the “Melodyne” subfolder of the “Applications” folder. The plug-ins are also called “Melodyne” and you 

will find them in: Macintosh HD/Library/Audio/Plug-Ins/<Subfolder of the plug-in type in question>.

Under Windows, the stand-alone implementation is called “Melodyne.exe”. You will find it under 

C://Programs/Celemony/Melodyne/ or C://Program Files (x86)/Celemony/Melodyne/. The various plug-

ins are also called “Melodyne” and are generally to be found here:

VST3 (64 Bit): C://Programs/Common Files/VST3/Celemony

VST3 (32 Bit): C://Program Files (x86)/Common Files/VST3/Celemony

VST2 (64 Bit): C://Programs/Common Files/Steinberg/VST2/Celemony (the path can be chosen at 

the time of the installation; please check to see which path your DAW is using)

VST2 (32 Bit): C://Program Files (x86)/Steinberg/VSTplugins/ (the path can be chosen at the time of 

the installation; please check to see which path your DAW is using)

AAX: C://Programs/Common Files/Avid/Audio/Plug-Ins

RTAS: C://Program Files (x86)/Common Files/Digidesign/DAE/Plug-Ins

In your DAW, you will find Melodyne among the audio effects plug-ins. To use it, insert the plug-in into 

the desired audio tracks.

I’ve installed Melodyne but do not know how to activate it.

Launch the stand-alone implementation of Melodyne. In the dialog box that appears, click on 

“Activate”. This takes you online to our registration page, where you can create a user account if you 

do not already have one. To do this, follow the onscreen instructions. When you have finished, your 

computer will be activated and you will be able to run Melodyne on it permanently and without 

restrictions. If you purchased Melodyne from our web shop, it is enough to click on “Activate”, as you 

will already have created your user account at the time of the purchase.
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I am getting error messages and cannot complete the activation.

To activate the program, you need a working Internet connection. Make sure – e.g. by trying to 

access another web site – that you are actually online. If you are, restart Melodyne and try again.

I would like to install Melodyne again but no longer have the installation program.

You will find your personal installation program in your user account. Log in at www.celemony.com

/login and download it to reinstall Melodyne.

I’m not sure whether the right edition and version of Melodyne is running.

To discover which edition and version number of Melodyne is running, choose “About Melodyne” from 

the main menu. If you need it, you will find the installation program for the Melodyne edition 

corresponding to your license in your user account (www.celemony.com/login).

I would like to know whether an update is available for my Melodyne.

Melodyne checks automatically via the Internet whether a newer version is available. You will find this 

function on the “Check for Updates” page of the Preferences dialog where you can also check for 

updates manually by clicking “Check Now”. We also provide information about updates in our 

newsletter, to which you can subscribe from your user account (at www.celemony.com/login).

I cannot launch the stand-alone implementation of Melodyne.

Restart your computer, then make a further attempt to launch Melodyne. If that does not work, delete 

your Melodyne preferences (instructions below) and try again. If Melodyne still will not launch, please 

contact our support at support@celemony.com. You will find your Melodyne preferences here:

• macOS: Hold down the Alt key in Finder and from the main menu choose Go > Library and open the 

Preferences subfolder. Scroll down to the file “com.celemony.melodyne.pref.plist” and delete it.

• Windows: Navigate to C://Users/<Your user name>/AppData/Roaming/Celemony/ and delete the file 

“com.celemony.melodyne.plist”. If the “AppData” folder is not visible, open the Control Panel by 

clicking the Start button (Windows 7) or right-clicking in the bottom left-hand corner of the screen 

(Windows 8). Now choose “Appearance and Personalization” followed by “Folder Options”. Click on 

the View tab. Under “Advanced Settings”, check “Show hidden files, folders, and drives” and exit with 

OK. 

I have inserted Melodyne as a plug-in in one of the audio tracks of my DAW but nothing 

is happening.

Initially Melodyne is empty; before it can do anything, audio material has to be transferred to it from 

the relevant track of the DAW. To do this, click the Transfer button in Melodyne and then, from the 
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DAW, play the passage you wish to edit. Once you have finished the transfer, the notes will appear in 

Melodyne and you will be able to edit them.

I have the impression that my DAW and Melodyne are not interacting correctly.

Many DAWs have particular characteristics of which you need to be aware, such as whether or not 

they support the ARA interface extension. In our Help Center, you will find the required information 

and tips on all leading DAWs. You can reach our Help center from Melodyne’s Help menu or under 

www.helpcenter.celemony.com.

I am not getting any audio output with the stand-alone implementation of Melodyne.

Open the Audio page of the Preferences dialog and make sure that the correct audio device is 

selected. Under macOS that should be the built-in audio hardware or your audio interface (and not, 

for example, the wireless interface Airplay). Under Windows, please select the correct ASIO driver. 

With DirectX no recording is possible.

After transferring or importing audio, the blobs in Melodyne are not at all as I expected.

By default, Melodyne selects an algorithm for your audio material automatically. It can happen from 

time to time that monophonic material is interpreted as polyphonic. If this happens, click on a note in 

the affected passage and select from the main menu under “Algorithm” an algorithm better suited to 

your purpose.

Sometimes, I can only move the blobs in the Note Editor vertically, sometimes only 

horizontally.

If you are editing a blob using the Main Tool (the arrow symbol), it is the initial direction of the drag 

that determines whether the blob can be moved vertically or horizontally. Release the blob 

momentarily if you wish to change direction. If the Pitch or Time grid is active, you will need to hold 

down the Alt key to make fine adjustments in the dimension concerned. When moving blobs 

horizontally, remember that it makes a difference whether you begin dragging from the middle of the 

blob or from either the beginning or the end. In the former case, the whole blob is moved; in the latter, 

only the beginning or end.

When I shift the pitch of certain blobs, they sound unnatural.

Occasionally, in the detection of monophonic audio material, octave errors can occur, and in that of 

polyphonic audio, prominent overtones can be mistaken for separate notes. In such cases, when the 

corresponding blobs are moved, artifacts can arise. You can prevent this by checking, and if 

necessary editing, the detection in Note Assignment Mode before you start, to ensure that the notes 

displayed really do correspond to those actually played.
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In the stand-alone implementation, the tempo of an imported audio file is wrong.

Activate the Auto Stretch switch to adapt the file you are importing to the project tempo. Deactivate it 

if you wish the original tempo of the imported file to be retained. If, in the former case, the tempo of 

the imported file is still wrong, open the file first in a separate project document and correct the tempo 

assignment there before copying the blobs into the first project.
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